Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

OpenVPN and 3CX phone for Android

Discussion in 'Android' started by Gabriele, Aug 20, 2012.

Thread Status:
Not open for further replies.
  1. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    Hi, I'm try to using my Motorola Defy with 3CX Phone and OpenVPN, but I can't heard anything.. The extension is correctly registered on 3CX server and VPN works correctly (I can use RDP for example) 3CX Phone works correctly (obviously) throught tunnel, but with VPN there is no audio..
    On 3CX Management I see that the IP is the one of internal (remote) LAN, not the one assigned by VPN, could it be the problem? How can I solve?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,110
    Likes Received:
    329
    Is STUN disabled?
    Are you establishing the VPN connection, and then starting 3CX?
     
  3. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    Is it possible to stop this SPAM?
     
  4. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    Yes, obviously..

    STUN server is disabled on 3CX server, on Android client I leave empty the field.

    The problem is only for audio, because the registration works, so I think that VPN works..
     
  5. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    I've made some test and the problem seems this one: 3CX register correctly Android client, but with the wrong (internal) IP address.
    For example: 3CX ip is 192.168.0.1/24, OpenVPN client IP address is 192.168.1.1/24, remote WiFi IP address is 192.168.2.1/24
    On 3CX server, in phone tab I have Android client, but IP showed is 192.168.2.1
    If I start OpenVPN on another Windows PC (192.168.2.2) in the same Wifi LAN and register on 3CX server the Windows Softphone, on 3CX server is correctly showed OpenVPN address (192.168.1.1) and in fact calls working fine.
    I don't know if you can solve the problem (that isn't so uncommon), but I can offer you all help to try to debug the problem and try beta version..
    I have a Motorola Defy with ICS 4.0.4 rooted

    Thanks
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,110
    Likes Received:
    329
    Do you have the 3CX phone options set-up as if you are in the office (on the same LAN as the 3Cx server). I'm not sure why it is sending the local WiFi IP rather than the one assigned by the VPN. It almost sounds like a STUN issue.
     
  7. Gabriele

    Joined:
    Oct 12, 2011
    Messages:
    13
    Likes Received:
    0
    Yes, I've set 3CX as in office. I've tried setting STUN to stun.3cx.com (as default) or leave it empty but the problem still remains..
    Other idea or test that I can do? Any help is greatly appreciated.
     
Thread Status:
Not open for further replies.