Original Caller ID on Forwarded calls to External Number

Discussion in '3CX Phone System - General' started by max1, Dec 9, 2015.

Thread Status:
Not open for further replies.
  1. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    Hi

    I forward calls to my mobile when I am out of the office. How do I get 3CX to forward the original Caller ID?

    Thanks

    Max
     
  2. Aram

    Aram Support Team
    Staff Member 3CX Support

    Joined:
    May 7, 2012
    Messages:
    123
    Likes Received:
    23
    Hi max1,

    You can add/modify Outbound Parameters of your SIP Trunk/PSTN GW, but first you need to check is that modification is supported by your SIP Trunk/PSTN GW.
    For example:
    You can configure "Remote Party ID - Called Party" fields to show the "OriginatorCallerID" specified, but first you need to check is this field is supported by your SIP Trunk/PSTN GW.
     
  3. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    803
    Likes Received:
    45
    Are you sure about this?
    Not the "Remote Party ID - Calling Party" field????
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,397
    Likes Received:
    273
    I actually use the "From: User Part" for this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    Thanks guys but I'm a bit confused to which one(s) I change. Please would you clarify?

    My SIP provider says they support this but won't help me with 3CX.

    Max
     
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,397
    Likes Received:
    273
    I change only "From: User Part" to "Originator Caller ID" and it works for me - and has on several providers.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    Thanks for the confirmation. I have tried this but it is still not working.

    My provider is Gradwell and I have gone back to them for more help. I will update here when I know more.
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,847
    Likes Received:
    299
    I found that, with my provide, Remote Party ID-Calling Party-User Part had to be changed to "OriginatorCallerID" for CID to be passed, when using "ring my mobile at the same time". I don't use call forwarding so I can't say if the result would be the same.
     
  9. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    @leejor Unfortunately my provider denies the call l when I change that field :(
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,847
    Likes Received:
    299
    Does your provider allow you to send an originating CID other than the one that is assigned to you. I know that many don't. In some countries it is actually forbidden (by law) to spoof caller ID, which is, in reality, what you are attempting to do.

    Choose an extension, in the settings you can put a number to be displayed. Normally this field is blank. I found that if I put any number in there, that is what is displayed to the called party on an outside call. My provider simply passes it along. If you change that, does the call still go through, or is it blocked? if it is blocked than you need to ask your provider if they are blocking calls with an "incorrect" CID. If that is the case, then you are out of luck.
     
  11. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    I tried your suggestion and the call failed. SO I presume they do not allow spoofing. I have contacted them for further assistance.

    Thanks
     
Thread Status:
Not open for further replies.