OS Version ?

Discussion in '3CX Phone System - General' started by MikeSr, Jan 27, 2007.

  1. MikeSr

    Joined:
    Jan 23, 2007
    Messages:
    27
    Likes Received:
    0
    The manual says Windows XP,2000 or 2003. I have been testing on XP Home edition. Having absolutely no luck! Is the Home edtion the potential problem ?
     
  2. MikeSr

    Joined:
    Jan 23, 2007
    Messages:
    27
    Likes Received:
    0
    Not XP version ?

    I have installed the 3cx on XP pro machine. No differance. When I add the PSTN lines through the GXW4104 the "Server Status" shows
    10:28:33.137 AuthMgr::eek:nAuthFailure: Registration request from sip:10001@192.168.1.5 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    10:28:33.137 AuthMgr::requestCredential: AuthID: 9466122 is not found in database!

    This is just one of the four lines with similar message. What I am entering wrong and where.
     
  3. MikeSr

    Joined:
    Jan 23, 2007
    Messages:
    27
    Likes Received:
    0
    Apache Service Problem

    I noticed in the MS system event viewer the following message:

    The Apache service named reported the following error:
    >>>> Apache.exe Could not determine the server's fully qualified domain name, using 192.168.1.99 for Server Name.

    I suspect this to be the problem since the event occurs when I an trying to Launch 3cx. Any ideas as to how to resolve this?
     
  4. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    321
    Likes Received:
    0
    The PBX is reporting that the credentials supplied don't match.

    I have a working setup with the following configs...

    On the GXW:

    In the channels tab, on the first line you should have something like:

    Channel: 1
    SIP User ID: 10001
    Authenticate ID: 10001
    Authen Password: 10001
    Profile ID: Profile 1

    now click the "Update" button at the bottom of the GXW config page

    In the Profile 1 tab, you should have something like:

    Activate Profile: Yes
    Profile Name: pbx
    SIP Server: 192.168.1.99 (assuming it is the address for the PBX Server machine)

    now click the "Update" button at the bottom of the GXW config page

    this procedure will save the new settings, but the GXW will only correctly apply them after a reboot - but we'll delay that for a bit until we get the rest done...

    On the 3CX PBX Server Management Console (assuming you have already configured the Gateway on the PBX Server for a single line):

    go to Lines->Manage
    Click the "Manage Gateways and Providers" button
    tick the checkbox next to the Grandstream Gateway you have configured and then click the "Edit Selected" button

    You should have something like:
    Gateway hostname or IP: 192.168.1.5 (assuming it is the address for the GXW)
    Gateway Port: 5060
    Gateway Outbound Caller ID: 10001

    now go to Lines->Manage (again)
    tick the checkbox nest to the line you have defined for the GXW and then click the "Edit Selected" button

    You should have something like:

    External Number: 10001
    Internal Number: 10001
    Allow Incoming calls: ticked
    Allow Outgoing calls: ticked
    Answer after: 0
    ID: 10001
    Password: 10001

    ... and set office hours and out-of-office hours routing to go to an extension - say Extension 100

    at this stage, go back to the GXW config page and reboot the GXW - which will get the device to register with the 3CX PBX Server using the new settings

    You will also need to ensure that you have an entry in "Outbound Rules" with for example "0" as prefix, and "r" as transform mask, and assigned to the "GXW" gateway. That way, when you dial "096537447" from a SIP phone, the PBX will identify the call as an outgoing call to be routed via the GXW, and will remove the leading "0" from the number before dialing the number on the PSTN line "96537447".

    This is the basic starting config - and I can confirm it works for me. You can then slowly tweak things to reflect, for example, your actual outbound caller ID, but the basic settings outlined above will work and correctly route calls in and out.

    Please tell me how it goes ;)
     
  5. MikeSr

    Joined:
    Jan 23, 2007
    Messages:
    27
    Likes Received:
    0
    That did it

    Kevin,
    Thanks, that did it. Here is what was different on my end.

    Lines Add PSTN:
    Line Number field was the "3915008" Real Phone number.
    Internal number was left as assigned 10003
    ID was "Line4"
    Password was "PW4"
    " Typical for other three channels"

    These items matched in the GXW
    Channels: SIP User ID Authenitcate ID Authen Password Proifile ID
    1 10000 Line1 PW1 Profile 1
    2 10001 Line2 PW2 Profile 1
    3 10002 Line3 PW3 Profile 1
    4 10003 Line4 PW4 Profile 1

    I also had all field matching at one time using the real phone numbers in all fields in both the 3cx line config and the GXW, but it didn't want to register.

    Keeping as you have indicated does work.

    Oh, I don't think I used your sequence. Config the lines in GXW and wait. I allways configed the lines in 3cx, config GXW and then reboot. Your sequence makes sense.

    I will continue to keep you posted . You have been a great help. Thank you again for your kind and accurate responce.

    Mike Sr
     

Share This Page