Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Out of Office Hours Timezone Problem

Discussion in '3CX Phone System - General' started by EdanBrooke, Jul 12, 2017.

Thread Status:
Not open for further replies.
  1. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Hi all,

    I'm working for a company as a web developer and have taken on the task of installing and maintaining their 3CX instance. My boss has requested that the phone not ring outside of office hours, so I thought "Great, that's easy enough, I'll just configure an out of hours destination."

    I awoke this morning to a message from the operations manager stating that no calls were coming through and that the phone was in out of hours mode and shouldn't be. Upon investigation, I found that it is likely to be a timezones issue.

    We are based in the United Kingdom, which follows Daylight Savings (DST). The server is configured to use UTC. In 3CX timezone settings, 00:00 United Kingdom (London) is selected. However, the clock is still behind by an hour and voicemail timestamps are also behind by 1 hour.
    However, elements such as the event logs are in UK time as expected.

    Any solid solution to this that doesn't break when we go from BST (GMT+1) back into GMT would be appreciated.

    Kind regards,
    Edan Brooke
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    Hello @EdanBrooke,

    Please note that the 3CX phone system uses the time of the server host to switch to in or out of office hours. The timezone in the PBX settings is used for provisioning phones to the correct time zone. So make sure that the host time is correct and try again
     
  3. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Hello and thank you for replying,

    My problem is that the server isn't in London. Should I change it to London regardless of the server's geographical location?

    Kind regards,
    Edan Brooke
     
  4. Saqqara

    Saqqara Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,252
    Likes Received:
    203
    It does not matter where the server is , the timezone can be any of the options - the main thing is where the phones are

    As above, change the time zone to London, and everything should work at it should
     
    #4 Saqqara, Jul 13, 2017
    Last edited: Jul 13, 2017
    EdanBrooke likes this.
  5. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Hi @Saqqara

    Thanks for your reply: I will try this and see how it goes.

    Kind regards,
    Edan Brooke
     
  6. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Code:
    You have received a new voice mail from "102 -"Edan Brooke"
    
    From:102
    To: 102" - "Edan" "Brooke"
    Received:"2017-07-14 09:21:32"
    Duration:"00:00:10"
     File:"vmail_102_102_20170714092132"
    This message was actually received at 10:21:32. Do I need to reboot the PBX for the changes to take effect? As it's in a production environment and I want to try and avoid disruption.
     
  7. Dennis Little

    Joined:
    Jul 19, 2017
    Messages:
    2
    Likes Received:
    3
    @EdanBrooke did you find a resolution to your problem? I am also experiencing the same issue on 15.5

    The server has been configured for my local time zone and the 3CX logs seem to show correct local times. However, my calls go to after-hours IVR during office hours.
     
    EdanBrooke likes this.
  8. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Not as of yet: if I remember, I'll restart the server this weekend when the company isn't receiving calls and see if that fixes the problem. (After changing the server's timezone)
     
  9. Dennis Little

    Joined:
    Jul 19, 2017
    Messages:
    2
    Likes Received:
    3
    @EdanBrooke thank you for your quick reply.

    FYI, global Office Hours operates correctly following local timezone setting change and server reboot; I was not able to immediately figure out which 3CX daemon would need to be restarted so that 3CX read new local server time.

    On a side now, it seems odd that 3CX doesn't follow the timezone defined in web settings and instead reads the local UTC time of the server; I presumed that Office Hours would follow that same timezone setting, mistakenly. Apparently the web-based timezone setting is only for phones provisioned through 3CX.

    For those provisioning through PBX Express on Amazon Web Services (AWS), on a Debian VM, you can fix the Office Hours issue:
    • SSH to your AWS VM
    • sudo dpkg-reconfigure tzdata
    • Set correct local timezone
    • Reboot VM
    • 3CX Office Hours should now work as expected
     
    EdanBrooke and AGidi like this.
  10. AGidi

    Joined:
    Jun 30, 2017
    Messages:
    49
    Likes Received:
    6
    I had the same issue.

    You need to do as Dennis said.
    Set the servers time
    Set the servers timezone
    Set the 3CX timezone
    restart the 3cx or the whole vps.

    For reference look at the chart in the dashboard. Should have the same time if its local to your location.
     
    EdanBrooke likes this.
  11. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    I will restart the VPS tomorrow once I've cleared this with my boss. Hopefully it will work :)
     
  12. AGidi

    Joined:
    Jun 30, 2017
    Messages:
    49
    Likes Received:
    6
    You can try and restar the services from the dashboard. Click on the services display. Select them all. Restart. Cross fingers.
    Takes about 30 secs.

    Best luck
     
  13. EdanBrooke

    Joined:
    Jul 2, 2017
    Messages:
    12
    Likes Received:
    0
    Hi,

    I re-started the server Friday evening and that's fixed timestamps on voicemail notification e-mails so I guess that'd fix out of office hours also.
    Fantastic!

    Thanks all.
     
Thread Status:
Not open for further replies.