Outbound anonynous

Discussion in '3CX Phone System - General' started by zcc3cx, Dec 4, 2015.

Thread Status:
Not open for further replies.
  1. zcc3cx

    Joined:
    Nov 29, 2015
    Messages:
    13
    Likes Received:
    0
    Hello,

    3CX 14

    I search but can not find it.

    Is it possible to give a extention group a outbound caller id?
    A customer wants for some extention groups a specific outbound caller id.
    And is it possible to set that id to be anonymous?

    Or, if outbound caller id for group extentions is not possible, how do we set a outbound caller id anonymous for a extention.


    Regards,
    Jan
     
  2. Aram

    Aram Support Team
    Staff Member 3CX Support

    Joined:
    May 7, 2012
    Messages:
    119
    Likes Received:
    23
    @zcc3cx
    Hi,

    It is not possible to modify the Outbound Caller ID according to Extension Group.
    To hide the Outbound Caller ID (send Privet Number, Anonymous, or something else) you need to use the "Block Outbound Caller ID" feature.
    You can find it in the Settings->PBX->Dial Codes page. By default it is configured as *5, so if you will dial *5123456789, your Outbound Caller ID will be hided and "Privet Number" will be send to remote user.
    *5 dial code is configurable and can be modified from the same page.
    "Privet Number" is not configurable for now, but it can be changed from the custom parameters.
    We are strongly suggesting to not modify the custom parameters, but if this hiding string is very critical for your customer, go to Troubleshooting->Parameters tab, search for "HIDECALLERIDINFO" custom parameter, change the Privet Number value to, let say, Anonymous. Be sure that you didn't touch any other custom parameter and press OK.
     
  3. max1

    Joined:
    May 16, 2014
    Messages:
    21
    Likes Received:
    0
    Hi,

    I have a customer that wanted all calls to be anonymous but I could not find a way of doing this. Luckily in the UK if we prepend the number with 141 it make the call anonymous.

    So for the extension group I created a new Outbound Rule and in the Prepend field I put 141. Now all calls get the code prepended and are anonymous.

    Can you do similar?

    Hope that helps

    Max
     
  4. zcc3cx

    Joined:
    Nov 29, 2015
    Messages:
    13
    Likes Received:
    0
    Thanx Aram, max1

    I'll wil try both solution soon.

    Regars,
    Jan
     
  5. zcc3cx

    Joined:
    Nov 29, 2015
    Messages:
    13
    Likes Received:
    0
    @Aram,

    *5123456789 works when dialing from a 3xphone app. Receiver see Anonymous. That's great.
    But we can't say to everyone to ad *5 to all outgoing calls :)

    2th option. Don't works here. 3CX v14 sp2.
    Change the Privet Number value to Anonymous. Receivers still sees caller id number.
    After restarting services receiver caller id number still visable.

    Is there a other parameter to block all outgoing caller id to try?

    Regards,
    Jan
    (I'm dutch so my english may not so well)
     
  6. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    118
    Likes Received:
    7
    You are going to need to control this with the outgoing call rules. If you edit your outbound rule, or create a rule for a specific extension group you can prepend the *5 command to all extensions that are included in that rule for outbound calls.
     
  7. zcc3cx

    Joined:
    Nov 29, 2015
    Messages:
    13
    Likes Received:
    0
    @aberry

    That will not work because 3cx is removing the caller id when it sees the *5.
    Adding a *5 to the outgong call to the provider wil not work :)

    Jan
     
  8. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    118
    Likes Received:
    7
    It seems to me that giving several numbers the same caller ID will fix your first question. What I would do is create a new extension group. Add the extensions that you want to share a caller ID to that group. After that you would either go into each extensino and give them a common caller ID, or alternatively if you want them to be anonymous you would create a new outgoing rule, that applies only to that extension group and prepend the *5.
     
  9. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    790
    Likes Received:
    45
    Dag Jan,

    What you can try to do, and only if your VoIP provider allows you to change the Caller ID, is to setup the Outbound Caller ID field with 10x “0”. This field can be found here: SIP trunks – Provider Trunk Name – Edit Port – Other Options
    With every outgoing call you sent 0000000000 as Caller ID to the callee.
    If your provider does not allow you to manipulate the Caller ID then ask them if they are willing to suppress your Caller ID.

    BTW: Who is your provider, if I may ask?

    Did you know we also have a Dutch 3CX forum?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. zcc3cx

    Joined:
    Nov 29, 2015
    Messages:
    13
    Likes Received:
    0
    @All

    SOLVED!

    Thanx for helping me thinking in to the right direction.

    I aks the provider for the code to block caller line id and i get it.
    They call it: Calling Line ID Delivery Blocking per Call and it's *65

    So now i can create several outbound rules for extentions and/or extentions groups.
    Put *65 in the prepend field and i'm done.
    Keep it simple :) I'm glad.



    @complex1
    I know we have a ducth forum but i think more people are reading here :)
    Off top:
    I have a other problem with a PSTN Gateway Grand stream GXW4108 who's working good in version v11 but not in v14. (Edit: solved)
    I'll wil open soon a new question in the forum for this in the english & ducht forum.

    Regards,
    Jan
     
Thread Status:
Not open for further replies.