Outbound-call problem with Grandstream GXW4104

Discussion in '3CX Phone System - General' started by osi-admin, Oct 13, 2010.

Thread Status:
Not open for further replies.
  1. osi-admin

    Joined:
    Oct 13, 2010
    Messages:
    2
    Likes Received:
    0
    We have configured the 3CX Phone System to work with the Grandstream GXW4104 gateway in accordance with the instructions posted.

    All extensions appear to be working.

    Incoming calls are successfully routed to the Digital Receptionist and then routed to the correct extensions.

    The problem is with outbound calls. All outbound calls lead to "Server Failure," which can be traced to "503 Service Unavailable." The outbound calls are configured to use a "9" prefix, which is configured to be stripped by the Phone System prior to sending the number to the Grandstream gateway. The attached Server Activity Log confirms that the appropriate data was sent.

    Three PSTN outside lines are connected to the Grandstream gateway, which is therefore configured to do Round-Robin of the three lines. The 3CX Phone System is also configured to use only three lines.

    We have searched the forum and found several postings of similar problems, but none seemed to have led to totally successful resolution. Any information to help us get through this will be much appreciated.
     

    Attached Files:

  2. osi-admin

    Joined:
    Oct 13, 2010
    Messages:
    2
    Likes Received:
    0
    Re: Outgoing-call problem with Grandstream GXW4104

    PROBLEM RESOLVED: Our investigation led us to search the forum at Grandstream for solutions, and we came across a friend who had success with a similar installation. He had encountered the same problem and finally sought help from Grandstream technical support. They informed him that there are variations in the phone lines among different localities and the Grandstream gateways would have to be configured accordingly.

    The following are parameter values that made his system work, and they also made our system work. Under FXO Lines:

    "FXO Termination" -> "1. Enable Current Disconnect(Y/N):" -> "If enabled, use threshold:" 300 (default was 100).

    "Channel Dialing to PSTN" -> "3. Min Delay Before Dial PSTN Number:" 750 (default was 500).

    In appreciation of the help we have received from this friend (a total stranger, really), we share this information with anyone who may stumble on the problem we have encountered.
     
Thread Status:
Not open for further replies.