Outbound CallerID Nextiva

Discussion in '3CX Phone System - General' started by LCC, Oct 4, 2011.

Thread Status:
Not open for further replies.
  1. LCC

    LCC

    Joined:
    Jul 8, 2011
    Messages:
    42
    Likes Received:
    0
    I don't recall having quite the problem setting outbound CallerID up on CallCentric, but I'm having a heck of a time getting the DID's to show on the proper extensions when dialing externally on Nextiva. Can someone let me know what outbound paramenters to modify? I have 3 DIDs on a SIP Trunk. I have messed with several but fear I am in a viscous cycle... :)

    Thanks.
     
  2. t0ken407

    Joined:
    Jan 28, 2013
    Messages:
    2
    Likes Received:
    0
    Did you ever find an answer to this?
     
  3. sn00per0

    Joined:
    Mar 29, 2013
    Messages:
    1
    Likes Received:
    0
    I have FINALLY got this setup working properly.

    My Nextiva setup w/3CX
    2 trunks (2 simultaneous calls)
    3 DIDs

    Setup on Nextiva site:
    Configure 1 device (i.e. myPBX), assign all 3 DIDs to the device, DO NOT SPECIFY OUTBOUND CID/name on the Nextiva portal!!!!

    Setup 3CX:
    1. Setup a "Generic SIP Trunk" provide the IP as "trunking.voipdnsservers.com" this is important
    2. Enter authentication information that you created on the Nextiva portal for the device (i.e. myPBX)
    3. Complete the Wizard...
    4. Setup all your DIDs on the Nextiva SIP trunk created in step 1
    5. For each extension to have its unique CID, you must set the CID number under the Other tab for the extension. Fill out the "Outbound Caller ID" field with whatever CID number you want that extension to set when you dial. For me in the US, I must set the 10 digit number (excluding the 1) so I set the CID number to 7894561234 (that number is sent to Nextiva (configured later) and they pass it through properly). Also note that you cannot just send ANY number, it must be one that you are authorized to own/send.
    6. Modify the "Outbound Parameters" for the Nextiva trunk you configured in #1 - select the Trunk name under Voip Providers, Select the "Outbound Parameters" tab.
    7. On my setup I've cleared ALL of the Contents of SIP fields (didn't seem ANY are necessary) and cleared ALL of the check boxes for "Location of the destination number"
    8. Now add the 1 SIP field required for outbound CID
    9. Set the SIP Field pull down to: "From : Display Name"
    10. Set the Variable to: "OutboundCallerID" Outbound caller Id taken from Extension settings in management console. (see step 5 to set those numbers)
    11. Press "Add/Update" to add the field to the table. (see attached screenshot)
    12. MAKE SURE TO PRESS OK or APPLY before making a test call.
    13. Dial happy and notice that the proper outbound CID/extension is being sent.

    Good luck!!!
    BTW: Nextiva support is 2 levels BELOW useless when asking questions like "What SIP field should I set so your system can recognize outgoing CID?" USELESS THEY ARE!!!!!
     

    Attached Files:

Thread Status:
Not open for further replies.