Outbound calls going to a record-route address

Discussion in '3CX Phone System - General' started by Vancouver9018, Dec 4, 2012.

Thread Status:
Not open for further replies.
  1. Vancouver9018

    Joined:
    Dec 4, 2012
    Messages:
    2
    Likes Received:
    0
    I use thinktel for a voip provider. For host / IP if I enter edm.trk.tprm.ca (which resolves to 208.68.17.52) then when I place a call my INVITE packet gets sent to 208.68.17.52 as expected. But Thinktel wants to tighten their security and since the host name is inserted into the INVITE request line, this causes problems for thinktel. They want me to change my sip server setting to the IP instead of hostname. When I use 208.68.17.52, 3cx will then use 208.68.17.142 to place outbound calls. This .142 number is an internal IP for thinktel. The only reference I can find to .142 is in the SIP record-route header. I can't figure out why 3cx is choosing to use that instead of .52.
     
  2. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Hi,

    Make a whireshark capture of one call and upload it here. Maybe we can figure out this way.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Vancouver9018

    Joined:
    Dec 4, 2012
    Messages:
    2
    Likes Received:
    0
    This issues is resolved now. Solution was to remove and re-add the Voip provider settings and now I can't get it to happen again. There was some sort of glitch where 3cx was incorrectly following the record-route headers. I walked through the pcap files several times comparing them against a working 3cx pbx. Every header looked correct, 3cx was simply trying to send invites to the wrong IP.

    This problem was persistent across a pbx reboot and service pack updates from SP1 to SP5 (of version 10). And then re-adding the voip provider fixed it.
     
Thread Status:
Not open for further replies.