Outbound calls not working, inbound fine

Discussion in '3CX Phone System - General' started by dvs4man, Nov 8, 2009.

Thread Status:
Not open for further replies.
  1. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    I cannot reach a number on the outside of the phone system. I am testing this with the broadvoice service.
    When I try to dial-out, I get "Called number does not exist" on the phone.
    The logs are attached below, where 'nnnnnnnnnnn' is the number I am dialing out to.
    Also note, although it says below in the bottom 2 lines that it is 'Registered' ok, the Ports/Trunk are of 3CX states it is still not registered.
    I am guessing since I can receive calls from the the outside, that there is some kind of outbound parameter issue I am having.

    If anyone can help, it would be greatly appreciated.

    Thanks.

    21:20:04.201 [CM503008]: Call(6): Call is terminated
    21:19:59.145 Session 4619 of leg C:6.1 is confirmed
    21:19:59.059 [CM503007]: Call(6): Device joined: sip:EndCall@127.0.0.1:40600;rinstance=a2b37f4c796f0b1b
    21:19:59.052 [CM503007]: Call(6): Device joined: sip:10@192.168.0.198:5060
    21:19:59.048 [MS210005] C:6.1:Answer provided. Connection(proxy mode):192.168.0.168:7018(7019)
    21:19:59.045 [MS210001] C:6.2:Answer received. RTP connection[unsecure]: 127.0.0.1:40618(40619)
    21:19:59.042 Remote SDP is set for legC:6.2
    21:19:59.032 [CM503002]: Call(6): Alerting sip:EndCall@127.0.0.1:40600;rinstance=a2b37f4c796f0b1b
    21:19:58.894 [CM503025]: Call(6): Calling Unknown:Ext.EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=a2b37f4c796f0b1b]
    21:19:58.891 [MS210004] C:6.2:Offer provided. Connection(proxy mode): 127.0.0.1:7020(7021)
    21:19:58.844 [CM503016]: Call(6): Attempt to reach <sip:nnnnnnnnnnn@192.168.0.168> failed. Reason: Not Found
    21:19:58.843 [CM503014]: Call(6): No known route to target: <sip:nnnnnnnnnnn@192.168.0.168>
    21:19:58.834 [CM503010]: Making route(s) to <sip:nnnnnnnnnnn@192.168.0.168>
    21:19:58.833 [MS210000] C:6.1:Offer received. RTP connection: 192.168.0.199:5016(5017)
    21:19:58.832 Remote SDP is set for legC:6.1
    21:19:58.831 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Aastra MBU/01.30 (MAC=00087B0753C8; HW=7)] PBX contact: [sip:10@192.168.0.168:5060]
    21:19:58.820 [CM503001]: Call(6): Incoming call from Ext.10 to <sip:nnnnnnnnnnn@192.168.0.168>
    21:19:58.813 [CM500002]: Info on incoming INVITE:
    INVITE sip:nnnnnnnnnnn@192.168.0.168 SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.198;branch=z9hG4bKci51geef7;received=192.168.0.199
    Max-Forwards: 70
    Contact: <sip:10@192.168.0.198>
    21:19:32.875 [CM504004]: Registration succeeded for: 10001@broadvoice
    21:19:32.346 [CM504003]: Sent registration request for 10001@broadvoice
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    This would suggest that you haven't defined any outbound rules, or haven't done them properly, so 3Cx doesn't know what to do with the dialed number. You have to tell 3cx exactly what to do with any dialed number that is not an internal extension/voicemail or other 3cx service.
     
  3. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    Thanks Leejor. I am not sure what outbound rules to build? Meaning, I have it connected to broadvoice, and setup the 'Outbound rules' for broadvoice, so in that area it simply has rule 1 as 'broadvoice', with the strip digits as '1'.
    Where else do you setup any further rules to make outgoing calls?

    Also, I setup broadvoice's outgoing proxy to an area close to me, and now the Ports/Trunk shows green - registed, so that is a positive step.

    I also setup STUN in my phone device, thinking it might have been a gateway issue from the phone itself. I have an Aastra 400 MBU and 420d handset. I installed the phone as per Kerry's guide from the voipstore.

    Let me know what area to focus on, and possibly what settings I need to make to get past this problem.

    Thanks,
    Dale.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    If you've built an outbound rule and stripped any digits that you don't want to go out on then trunk group, then it should work. Did you specify that the out going call is to use the trunk that you data filled for your VoIP provider? It seems strange that it doesn't know where to send the call based on the digits that you dialed. If you are still having problems you may want to post exactly, or a number similar to,what you are dialing and what your provider wants to receive.
     
  5. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    I modified the outbound rule in that 'Calls to numbers starting with (Prefix)' of the value '1', then rule 1 gets used which is broadvoice and 'Strip digits' is set to '0' in the rule.
    It seems like it is getting further as per the log below:

    07:29:54.050 Remote SDP is set for legC:11.3
    07:29:54.041 [CM503002]: Call(11): Alerting sip:EndCall@127.0.0.1:40600;rinstance=2e8fcb36dc3894a0
    07:29:53.903 [CM503025]: Call(11): Calling Unknown:Ext.EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=2e8fcb36dc3894a0]
    07:29:53.899 [MS210004] C:11.3:Offer provided. Connection(proxy mode): 127.0.0.1:7040(7041)
    07:29:53.833 [CM503016]: Call(11): Attempt to reach <sip:nnnnnnnnnnn@192.168.0.168> failed. Reason: Forbidden
    07:29:53.826 [CM503003]: Call(11): Call to sip:nnnnnnnnnnn@sip.broadvoice.com has failed; Cause: 403 Forbidden; from IP:147.135.32.221:5060
    07:29:53.643 [CM503025]: Call(11): Calling VoIPline:nnnnnnnnnnn@(Ln.10001@broadvoice)@[Dev:sip:sip.broadvoice.com:5060]
    07:29:53.567 [MS210002] C:11.2:Offer provided. Connection(transcoding mode): 71.193.85.142:9010(9011)
    07:29:53.375 [CM503004]: Call(11): Route 1: VoIPline:nnnnnnnnnnn@(Ln.10001@broadvoice)@[Dev:sip:sip.broadvoice.com:5060]
    07:29:53.373 [CM503010]: Making route(s) to <sip:nnnnnnnnnnn@192.168.0.168>


    'nnnnnnnnnnn' is the '1(3 Digit Area Code I am dialing)(7 Digit phone number I am dialing)'. As noted above, I am getting the '403 Forbidden' now from IP:147.135.32.21, which is the 'sip.broadvoice.com' address you route your broadvoice calls to.

    I am curious why I am getting forbidden, since I get incoming calls fine.

    Also, in the 'Outbound Rules', how do you configure it so any number you dial simply gets routed to the 'sip.broadvoice.com' server to be processed and calls made?

    Let me know any more insights as to how to best configure this, and to get past the '403 Forbidden' issue.

    Thanks.
     
  6. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    ok. I have rechecked the broadvoice configuration on the account. So anyone else who reads this, I found from a voxilla forum that the account information is not what you sign up with for Broadvoice, it is on your account detail page, under the billing information. It has the Auth_ID and Auth_Password you should use, as well as the account ID. I had a '1' in front of the account ID in the broadvoice setup, took that out, now I do not get the '403 Forbidden' anymore. All I do get now is 'Not Registered'.

    07:54:50.664 [CM503008]: Call(15): Call is terminated
    07:54:42.365 Session 1481 of leg C:15.1 is confirmed
    07:54:42.208 [CM503007]: Call(15): Device joined: sip:EndCall@127.0.0.1:40600;rinstance=2e8fcb36dc3894a0
    07:54:42.201 [CM503007]: Call(15): Device joined: sip:10@192.168.0.199:5060
    07:54:42.197 [MS210005] C:15.1:Answer provided. Connection(proxy mode):192.168.0.168:7054(7055)
    07:54:42.191 [MS210001] C:15.2:Answer received. RTP connection[unsecure]: 127.0.0.1:40636(40637)
    07:54:42.187 Remote SDP is set for legC:15.2
    07:54:42.180 [CM503002]: Call(15): Alerting sip:EndCall@127.0.0.1:40600;rinstance=2e8fcb36dc3894a0
    07:54:42.010 [CM503025]: Call(15): Calling Unknown:Ext.EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=2e8fcb36dc3894a0]
    07:54:42.009 [MS210004] C:15.2:Offer provided. Connection(proxy mode): 127.0.0.1:7056(7057)
    07:54:41.998 [CM503016]: Call(15): Attempt to reach <sip:nnnnnnnnnnn@192.168.0.168> failed. Reason: Not Registered
    07:54:41.997 [CM503016]: Call(15): Attempt to reach <sip:nnnnnnnnnnn@192.168.0.168> failed. Reason: Not Registered
    07:54:41.996 [CM503017]: Call(15): Target is not registered: VoIPline:nnnnnnnnnnn dialed on (AnyLine@broadvoice)
    07:54:41.996 [CM303003]: There are no available outbound lines on gateway broadvoice at this time.
    07:54:41.993 [CM503010]: Making route(s) to <sip:nnnnnnnnnnn@192.168.0.168>
    07:54:41.993 [MS210000] C:15.1:Offer received. RTP connection: 71.193.85.142:5010(5011)
    07:54:41.991 Remote SDP is set for legC:15.1
    07:54:41.991 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Aastra MBU/01.30 (MAC=xxxxxxxx; HW=7)] PBX contact: [sip:10@192.168.0.168:5060]
    07:54:41.886 [CM503001]: Call(15): Incoming call from Ext.10 to <sip:nnnnnnnnnnn@192.168.0.168>
    07:54:41.873 [CM500002]: Info on incoming INVITE:


    Also, I can now dial-out without hearing the message "Called number does not exist" anymore. I saw in the 'Outbound Rules' that you can set the extension to the rule, which I did while I am testing this setup, and it works now.

    Let me know if anyone knows why it is not registered? It states the gateway, but what config makes that work correctly?
    Thanks.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    From the logs in your original post, it looks like Broadvoice was registering. Go back to your original settings. Make sure that 3CX shows the trunk as registered.
     
  8. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    Hello. I still cannot make outbound calls on Broadvoice, but get inbound calls fine.
    Is the number an issue in the outbound connection? XXXXXXXXXX@sip.broadvoice.com, where that is my original number at the end of the string?

    Look below, and let me know what you think? It has something to do with the string I am sending to broadvoice, but where else can I configure it to work correctly?

    09:25:24.135 [CM503008]: Call(2): Call is terminated
    09:25:24.080 [CM503020]: Normal call termination. Reason: Forbidden
    09:25:24.080 [CM503016]: Call(2): Attempt to reach <sip:{callingtothisnumber}@192.168.0.198;user=phone> failed. Reason: Forbidden
    09:25:24.074 [CM503003]: Call(2): Call to sip:{callingtothisnumber}@sip.broadvoice.com has failed; Cause: 403 Forbidden; from IP:147.135.32.221:5060
    09:25:23.933 [CM503025]: Call(2): Calling VoIPline:{callingtothisnumber}@(Ln.10000@broadvoice)@[Dev:sip:{mynumber}@sip.broadvoice.com:5060]
    09:25:23.626 [CM503004]: Call(2): Route 1: VoIPline:{callingtothisnumber}@(Ln.10000@broadvoice)@[Dev:sip:{mynumber}@sip.broadvoice.com:5060]
    09:25:23.625 [CM503010]: Making route(s) to <sip:{callingtothisnumber}@192.168.0.198;user=phone>
    09:25:23.622 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [A580 IP022140000000] PBX contact: [sip:10@192.168.0.198:5060]
    09:25:23.608 [CM503001]: Call(2): Incoming call from Ext.10 to <sip:{callingtothisnumber}@192.168.0.198;user=phone>
    09:17:53.181 [CM504001]: Ext.10: new contact is registered. Contact(s): [sip:10@192.168.0.188:5060/10]
    09:17:46.783 [CM504002]: Ext.10: a contact is unregistered. Contact(s): []
    09:14:25.919 [CM503008]: Call(1): Call is terminated
    09:14:25.865 [CM503020]: Normal call termination. Reason: Forbidden
    09:14:25.865 [CM503016]: Call(1): Attempt to reach <sip:1{callingtothisnumber}@192.168.0.198;user=phone> failed. Reason: Forbidden
    09:14:25.859 [CM503003]: Call(1): Call to sip:1{callingtothisnumber}@sip.broadvoice.com has failed; Cause: 403 Forbidden; from IP:147.135.32.221:5060
    09:14:25.693 [CM503025]: Call(1): Calling VoIPline:1{callingtothisnumber}@(Ln.10000@broadvoice)@[Dev:sip:{mynumber}@sip.broadvoice.com:5060]
    09:14:25.087 [CM503004]: Call(1): Route 1: VoIPline:1{callingtothisnumber}@(Ln.10000@broadvoice)@[Dev:sip:{mynumber}@sip.broadvoice.com:5060]
    09:14:25.084 [CM503010]: Making route(s) to <sip:1{callingtothisnumber}@192.168.0.198;user=phone>
    09:14:25.083 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [A580 IP022140000000] PBX contact: [sip:10@192.168.0.198:5060]
    09:14:25.070 [CM503001]: Call(1): Incoming call from Ext.10 to <sip:1{callingtothisnumber}@192.168.0.198;user=phone>
    09:14:04.126 [CM504004]: Registration succeeded for: 10000@broadvoice
    09:12:21.064 [CM504004]: Registration succeeded for: 10000@broadvoice


    Thanks.
     
  9. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    I am hoping someone has gotten Broadvoice connected successfully, with any phone.
    I just need to know why the 403 forbidden is happenning....
    Thanks.
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    If It were me...I would speak to Broadvoice to see if they can give any help on why the 403 "Forbidden" message.

    What does that mean, do they think you account isn't paid-up or is it that you are sending incorrect digits to them? They might be able to go into their logs to see why they are sending you that message.
     
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    If you are going to dial ALL outgoing calls, both local and LD AND you want to dial them with a "1", then you probably have it set up correctly, 1+ 1-0 digits (North America), don't strip any digits, and send call out on the Broadvoice trunk group.
    You could also set up for international calls dialling 011 first. Or, if you live an an area where you only have one area code, you could dial 9+XXX-XXXX, strip the 9 and add 1+ the local area code, before sending the call out on the Broadvoice trunk.

    It becomes more difficult to route outbound calls if you don't use some sort of "access digit", like a 9 as the first digit since 3Cx has internal numbers to take into consideration as well. It's not too bad when you have only one outgoing route but if you were to add a PSTN gateway for local calls then....
     
  12. dvs4man

    Joined:
    Oct 5, 2009
    Messages:
    50
    Likes Received:
    0
    Thanks Leejor. Broadvoice had the issue once I called them. This weekend, they had some issues, so it is good to see they have it resolved.
    All is working fine now.
    Thanks.
     
Thread Status:
Not open for further replies.