Solved Outbound Calls not working - Twilio

Discussion in '3CX Phone System - General' started by rickgeek1972, Mar 2, 2018.

Thread Status:
Not open for further replies.
  1. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    Join and install 3cx for a last days. and integrate with Twilio. Now inbound is working. but outbound is not working.

    1. Already checked the firewall - all are good
    2. Using Twilio SIP trunk and no issues so far
    3. When outbound called made, it rings one to two times and disconnected.
    4. Outbound rule - already set up one. set prefix 1-9 only.
    5. Call Logs: Most of them just shown no answer.
     
  2. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    I'm using Twilio, the guide from 3CX does work. Are you on prem or hosted?
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,754
    Likes Received:
    286
    So call logs show no answer, but you only get one or two rings?

    Is there a rejection/ timeout message?

    Sent digits are correct?

    Is your provider able to offer any information on what they see at their end?
     
  4. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    on hosted....the outbound call still not working.
     
  5. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    03/13/2018 9:29:31 PM - Call to T:Line:10000>>13105975787@[Dev:sip:10000@solutiononce.pstn.twilio.com:5060] from L:30.1[Extn:0000] failed, cause: Cause: 403 Forbidden/INVITE from 54.172.60.1:5060
     
  6. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    outbound rule: call to numbers 1-9
    call to number with a length: 10

    Above my setting - default rule. still not working
     
  7. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
  8. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    Do you have E164 disabled in settings? It needs to be off for Twilio. Here are the 3 outbound rules I have setup for Twilio.

    rule1.png rule2.png rule3.png
     
    John Dugan likes this.
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,754
    Likes Received:
    286
    I assume that IP is your providers...if so, they are rejecting the call. This is either because of the number you are sending (dialling), or the caller ID you are attempting to send. They should be able to tell you what it is they don't like.
     
  10. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    hrmny: I do exactly same settings according to your screenshot +
    I go to dashboard >> setting >> to unchecked e164.

    It is still not working. by the way, maybe I should reboot the server? if yes, how?
     
  11. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    To restart the 3CX services, on the Dashboard click the "Services" button in bottom left of the middle column. To reboot the server, on the Dashboard click "Terminal" and then type reboot and press enter.

    Are you seeing any error messages in your Twilio debug console?
    The outbound caller ID for the trunk configured +15551234567 or 5551234567?
     
  12. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    Error - 32202
    SIP: Bad user credentials
    Possible Causes
    • There is a Credentials List on your trunk, and your INVITE’s Authentication Digest is incorrect due to wrong username/password
    Possible Solutions
    • Confirm that your username/password matches one in your Credentials List.
     
  13. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    Do you have ACL credentials setup under the trunk in Twilio? And the matching credentials populated in 3CX under the trunk authentication?

    EDIT: Are you also using IP based authentication?
     
  14. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    Yes for both questions.
     
  15. rickgeek1972

    Joined:
    Mar 2, 2018
    Messages:
    9
    Likes Received:
    0
    so painful to deal with 3cx
     
  16. John Dugan

    Joined:
    Mar 13, 2018
    Messages:
    10
    Likes Received:
    0
    Thanks @HRMNY for those outbound rule screenshots. The outbound rules in the official 3CX/Twilio docs didn't work for me as they didn't distinguish between 10 and 11 digit calls for the length definition. Your recommendations should be incorporated in the 3CX/Twilio docs for US customers.

    I too can receive inbound calls, but cannot make outbound calls. Interestingly, I contacted Twilio and they said 3CX is not supported for their Elastic SIP Trunks.

    twilio.png
    This is very strange as Twilio is listed as one of four worldwide "tested and approved" SIP trunk providers by 3CX.

    However, I think my issue may be in the hostname that I am passing for authentication with Twilio. In it, my local IP is being passed. I need my public IP to be passed. My public IP is what's been added to the Twilio Access Control List (ACL). Currently, the 3CX dashboard log is showing something like this for outbound calls:

    `Device +1612xxxxxxx dialed on (AnyLine@Twilio) had no available outgoing trunk(s) for Call(from "John Dugan"<sip:000@192.168.x.x>;tag=276048214 to +1612xxxxxxx)`

    How do I change the local 192.168.x.x IP to my public IP that I am using for authentication with Twilio (along with my username and password credentials)?

    I think that because my local IP is being passed for outbound calls, I cannot authenticate with Twilio, and therefore, the SIP trunk cannot be registered.

    Thanks in advance for the help.
     
  17. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    Under "Settings>Network"

    How many Network Interfaces do you have?
    Are you using Static Public IP Address or STUN?
     
  18. John Dugan

    Joined:
    Mar 13, 2018
    Messages:
    10
    Likes Received:
    0
    1 network interface. Using STUN.
     

    Attached Files:

  19. HRMNY

    Joined:
    Feb 8, 2018
    Messages:
    22
    Likes Received:
    1
    Edge firewall brand?
    SIP ALG turned off on your edge firewall?
    3CX Firewall Check, test ok?
     
Thread Status:
Not open for further replies.