Outbound calls not working

Discussion in '3CX Phone System - General' started by belvoir, May 25, 2012.

Thread Status:
Not open for further replies.
  1. belvoir

    Joined:
    Jul 21, 2011
    Messages:
    15
    Likes Received:
    0
    I have setup a new installation of 3CX v10.0.24018.2322 SP.6

    I have 2 extensions with 3CX softphones on my network. I can make and receive calls via the internal LAN to/from these extensions.

    I have a SIP trunk from Entacall (UK) which I have configured (status is show as registered.

    I can receive calls from the PSTN via the SIP trunk to the extensions on the 3CX, but . . .

    I cannot make any outbound calls even though I have setup an "Outbound Rule".

    The softphone rings out for half a minute or so then ends the call.

    The Server Activity Log shows the following:

    14:54:24.514|.\CallLeg.cpp(143)|Log5||CallLeg::eek:nNewCall:[CM500002]: Info on incoming INVITE:
    INVITE sip:01480403009@192.168.192.101:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.192.70:56033;branch=z9hG4bK-d8754z-6203bb209256f538-1---d8754z-;rport=56033
    Max-Forwards: 70
    Contact: <sip:202@192.168.192.70:56033;rinstance=78b4eaf8fc3941a6>
    To: <sip:01480403009@192.168.192.101:5060>
    From: "Stuart"<sip:202@192.168.192.101:5060>;tag=98081a57
    Call-ID: MWZjYWFhMDFmODJkOTJjN2QxODJiZGU3NjhiNWViMDU.
    CSeq: 2 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REGISTER, SUBSCRIBE, NOTIFY, REFER, INFO, MESSAGE
    Proxy-Authorization: Digest username="202",realm="3CXPhoneSystem",nonce="414d535c05d0201039:5994aa1809b82dd57022e410451548fd",uri="sip:***********@192.168.192.101:5060",response="1172edf465744d5efa467931dc0673a5",algorithm=MD5
    Supported: replaces
    User-Agent: 3CXPhone 6.0.19548.0
    Content-Length: 0

    14:54:24.524|.\CallCtrl.cpp(346)|Log2||CallCtrl::eek:nIncomingCall:[CM503001]: Call(3): Incoming call from Ext.202 to <sip:***********@192.168.192.101:5060><br>
    14:54:24.529|.\Extension.cpp(1407)|Log3||Extension::printEndpointInfo:[CM505001]: Ext.202: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXPhone 6.0.19548.0] PBX contact: [sip:202@192.168.192.101:5060]<br>
    14:54:24.531|.\CallLeg.cpp(1194)|Log5||CallLeg::setRemoteSdp:Remote SDP is set for legC:3.1<br>
    14:54:24.534|.\CallCtrl.cpp(529)|Log3||CallCtrl::eek:nSelectRouteReq:[CM503010]: Making route(s) to <sip:***********@192.168.192.101:5060><br>
    14:54:24.534|.\SLServer.cpp(861)|Log5|MediaServer|MediaServerReporting::SetRemoteParty:[MS210000] C:3.1:Offer received. RTP connection: 192.168.192.70:40044(40045)<br>
    14:54:24.536|.\CallCtrl.cpp(708)|Log2||CallCtrl::eek:nSelectRouteReq:[CM503004]: Call(3): Route 1: VoIPline:01480403009@(Ln.10000@Entacall)@[Dev:sip:***********@proxy.entacall.com:5060]<br>
    14:54:24.536|.\CallCtrl.cpp(708)|Log2||CallCtrl::eek:nSelectRouteReq:[CM503004]: Call(3): Route 2: VoIPline:01480403009@(Ln.10000@Entacall)@[Dev:sip:************@proxy.entacall.com:5060]<br>
    14:54:24.537|.\CallCtrl.cpp(708)|Log2||CallCtrl::eek:nSelectRouteReq:[CM503004]: Call(3): Route 3: VoIPline:01480403009@(Ln.10000@Entacall)@[Dev:sip:************@proxy.entacall.com:5060]<br>
    14:54:24.709|.\SLServer.cpp(861)|Log5|MediaServer|MediaServerReporting::SetRemoteParty:[MS210002] C:3.2:Offer provided. Connection(transcoding mode): xxx.xxx.xxx.xxx:9000(9001)<br>
    14:54:24.716|.\Target.cpp(441)|Log2||Target::makeOneInvite:[CM503025]: Call(3): Calling VoIPline:***********@(Ln.10000@Entacall)@[Dev:sip:************@proxy.entacall.com:5060]<br>
    14:54:27.919|.\Call.cpp(42)|Log3||??:Currently active calls - 1: [3]<br>
    14:54:56.829|.\Call.cpp(1396)|Log2||Call::Terminate:[CM503008]: Call(3): Call is terminated<br>
    14:54:56.833|.\CallLeg.cpp(326)|Log2||CallLeg::eek:nFailure:[CM503003]: Call(3): Call to sip:***********@proxy.entacall.com:5060 has failed; Cause: 408 Request Timeout; internal<br>
    14:54:57.921|.\Call.cpp(48)|Log5||??:Currently active calls [none]<br>

    Finally, I get an email that says:

    (0) 3CX 25/05/2012 14:54:56

    Call to ***********@(Ln.10000@Entacall) has failed. [ V4 0.0.0.0:0 UNKNOWN_TRANSPORT target domain=unspecified mFlowKey=0 ] replied: 408 Request Timeout; internal

    Can anyone help please?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    I'm wondering if your PC, running 3CX has proper access to a DNS server (network settings?). You might want to substitute the IP of your provider, (It comes up as 87.127.240.101) rather than the URL, just as a test.

    Have you run the 3CX firewall test with success?
     
  3. belvoir

    Joined:
    Jul 21, 2011
    Messages:
    15
    Likes Received:
    0
    Hi

    Thanks for the response. The PC is running Windows 7 Professional and is attached to my LAN. The DNS server is a Windows SBS2008 server and DNS resolution appears to be fine. The Ports/Trunks Status shows up as "registered" so I'm assuming that DNS resolution is OK.

    I tried changing it to the IP address but it makes no difference.

    Firewall check runs with no errors.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    It appears that 3CX does not know how to route to the provider. Check over your trunk settings again.
     
  5. belvoir

    Joined:
    Jul 21, 2011
    Messages:
    15
    Likes Received:
    0
    Hi leejor

    I had more or less come to the same conclusion but I have no idea where to look - can you give me any clues?

    Thanks
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    What sort of information (besides the user and password) did you provider supply.
     
  7. belvoir

    Joined:
    Jul 21, 2011
    Messages:
    15
    Likes Received:
    0
    I got VoIP Number, username, password, proxy and domain. My VoIP control panel at the SIP Trunk Provider shows that I am logged in and that i'm logged on using 3CXPhoneSystem 10.0.23053.0 so I'm assuming that I have entered all the details correctly in the trunk settings on the 3CX.
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    Someone else have had a similar experience (logs). I'm wondering if it is the result of the same problem.

    http://www.3cx.com/forums/starview-voip-provider-19292.html#p105726
     
  9. belvoir

    Joined:
    Jul 21, 2011
    Messages:
    15
    Likes Received:
    0
    This person said "Finally got it for outbound calls, the FROM headers needed the external IP of our 3cx server, working on inbound calls now." What is meant by the FROM headers?
     
Thread Status:
Not open for further replies.