Outbound calls with Patton Gateway very slow

Discussion in '3CX Phone System - General' started by benoit.sauve, Oct 16, 2015.

Thread Status:
Not open for further replies.
  1. benoit.sauve

    Joined:
    Oct 16, 2015
    Messages:
    13
    Likes Received:
    0
    Hi!
    We have a problem since we installed 3CX System with Patton Gateway 4114 (4-FXO ports). We use only 2 lines.

    When we make an outbound call, it takes almost 15 seconds to get ringing. Here is a log when it takes 15 seconds :

    Leg L:53.3[Line:90001>>4507630325] is terminated: Cause: BYE from PBX
    [CM503008]: Call(C:53): Call is terminated
    Leg L:53.1[Extn] is terminated: Cause: BYE from 192.168.1.102:59224
    [CM503007]: Call(C:53): Line:90001>>4507630325 has joined, contact <sip:90002@192.168.1.5:5061>
    [CM503007]: Call(C:53): Extn:102 has joined, contact <sip:102@192.168.1.102:59224>
    L:53.3[Line:90001>>4507630325] has joined to L:53.1[Extn]
    [CM505002]: Gateway:[PATTON 4114] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Patton SN4114 JO EUI 00A0BA0B1131 R6.3 2013-05-01 H323 SIP FXS FXO M5T SIP Stack/4.1.12.18] PBX contact: [sip:90002@192.168.1.7:5060]
    Leg L:53.2[Line:90001>>4507630325] is terminated: Cause: 504 Server Time-out/INVITE from 192.168.1.5:5060
    [CM503025]: Call(C:53): Calling T:Line:90001>>4507630325@[Dev:sip:90002@192.168.1.5:5061] for L:53.1[Extn]
    Call to T:Line:90001>>4507630325@[Dev:sip:90001@192.168.1.5:5060,Dev:sip:90002@192.168.1.5:5061] from L:53.1[Extn] failed, cause: Cause: 504 Server Time-out/INVITE from 192.168.1.5:5060
    [CM503003]: Call(C:53): Call to <sip:4507630325@192.168.1.5:5060> has failed; Cause: 504 Server Time-out/INVITE from 192.168.1.5:5060
    [CM503025]: Call(C:53): Calling T:Line:90001>>4507630325@[Dev:sip:90001@192.168.1.5:5060,Dev:sip:90002@192.168.1.5:5061] for L:53.1[Extn]
    [CM503027]: Call(C:53): From: Extn:102 ("NAME" <sip:102@192.168.1.7:5060>) to T:Line:90001>>4507630325@[Dev:sip:90001@192.168.1.5:5060,Dev:sip:90002@192.168.1.5:5061]
    [CM503004]: Call(C:53): Route 1: from L:53.1[Extn] to T:Line:90001>>4507630325@[Dev:sip:90001@192.168.1.5:5060,Dev:sip:90002@192.168.1.5:5061]
    Line limit check: Current # of calls for line Lc:90004(@PATTON 4114[<sip:90004@192.168.1.5:5063>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90003(@PATTON 4114[<sip:90003@192.168.1.5:5062>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90002(@PATTON 4114[<sip:90002@192.168.1.5:5061>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90001(@PATTON 4114[<sip:90001@192.168.1.5:5060>]) is 0; limit is 1
    Call(C:53): Call from Extn:102 to 4507630325 matches outbound rule 'Règle pour PATTON 4114'
    [CM503001]: Call(C:53): Incoming call from Extn:102 to <sip:4507630325@192.168.1.7:5060>

    But if we already have an inbound call that use the line 0, then it takes 5 seconds to ring. Here is the log :

    Leg L:52.2[Line:90002>>4507630325] is terminated: Cause: BYE from PBX
    [CM503008]: Call(C:52): Call is terminated
    Leg L:52.1[Extn] is terminated: Cause: BYE from 192.168.1.102:59224
    [CM503007]: Call(C:52): Line:90002>>4507630325 has joined, contact <sip:90002@192.168.1.5:5061>
    [CM503007]: Call(C:52): Extn:102 has joined, contact <sip:102@192.168.1.102:59224>
    L:52.2[Line:90002>>4507630325] has joined to L:52.1[Extn]
    [CM505002]: Gateway:[PATTON 4114] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Patton SN4114 JO EUI 00A0BA0B1131 R6.3 2013-05-01 H323 SIP FXS FXO M5T SIP Stack/4.1.12.18] PBX contact: [sip:90002@192.168.1.7:5060]
    Currently active calls - 2: [49,52]
    [CM503025]: Call(C:52): Calling T:Line:90002>>4507630325@[Dev:sip:90002@192.168.1.5:5061] for L:52.1[Extn]
    [CM503027]: Call(C:52): From: Extn:102 ("NAME" <sip:102@192.168.1.7:5060>) to T:Line:90002>>4507630325@[Dev:sip:90002@192.168.1.5:5061]
    [CM503004]: Call(C:52): Route 1: from L:52.1[Extn] to T:Line:90002>>4507630325@[Dev:sip:90002@192.168.1.5:5061]
    Line limit check: Current # of calls for line Lc:90004(@PATTON 4114[<sip:90004@192.168.1.5:5063>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90003(@PATTON 4114[<sip:90003@192.168.1.5:5062>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90002(@PATTON 4114[<sip:90002@192.168.1.5:5061>]) is 0; limit is 1
    Line limit check: Current # of calls for line Lc:90001(@PATTON 4114[<sip:90001@192.168.1.5:5060>]) is 1; limit is 1
    Call(C:52): Call from Extn:102 to 4507630325 matches outbound rule 'Règle pour PATTON 4114'
    [CM503001]: Call(C:52): Incoming call from Extn:102 to <sip:4507630325@192.168.1.7:5060>

    Does anyone know what is happening. We configured the patton gateway using the config file generated by the 3CX config system.

    Thanks!

    Benoit
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,128
    Likes Received:
    210
    Would be helpful to see the timestamp from the log.
    And please provide logs in verbose mode as an attachment.

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    It would appears that the first attempt, on the first trunk, fails (times out), but the call does end up going through on the second trunk. It may be a network setting in the gateway (port number?), that is preventing the gateway from "seeing" the INVITE from the PBX. Check the settings in the gateway for line one, and, if available, check any gateway logs, or Syslogs.
     
  4. benoit.sauve

    Joined:
    Oct 16, 2015
    Messages:
    13
    Likes Received:
    0
    Hi!

    here is the log with timestamp in attachement. How can I configure verbose mode?

    Benoit
     

    Attached Files:

  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    19-oct.-2015 08:25:20.546 [CM503003]: Call(C:79): Call to <sip:4507630325@192.168.1.5:5060> has failed; Cause: 504 Server Time-out/INVITE from 192.168.1.5:5060
    19-oct.-2015 08:25:17.612 Currently active calls - 1: [79]
    19-oct.-2015 08:25:09.546 [CM503025]: Call(C:79): Calling T:Line:90001>>4507630325@[Dev:sip:90001@192.168.1.5:5060,Dev:sip:90002@192.168.1.5:5061] for L:79.1[Extn]

    The server time-out, is where the delay is first happening. As I said before, there appears to be no reply from the gateway to the call attempt on the first trunk, so...3CX is waiting until the timeout period occurs, then attempts to place a call on the second trunk.

    Gateways are set-up a bit differently than ATAs in that the port number that 3CX is sending to is not derived from a registration message, it is datafilled in the trunk settings of the PBX. That port number must match the one set for the corresponding trunk in the gateway, or it won't respond. If you used auto-provisioning, that should have all happened correctly. But, since the gateway does not seem to be responding to a call set-up on the first trunk, it may be a port mismatch.
     
  6. benoit.sauve

    Joined:
    Oct 16, 2015
    Messages:
    13
    Likes Received:
    0
    Hi!

    I created the gateway in the 3CX phone system, then I imported the configuration file generated in the Patton. That's all I did. Everything worked except this delay.

    I really don't understand.

    I tried to look at the SIP patton config but everything seems to be ok. I don't know where to look to find the problem.

    Benoit
     
  7. benoit.sauve

    Joined:
    Oct 16, 2015
    Messages:
    13
    Likes Received:
    0
    Hi!

    I found something I don't understand.

    Gateway port is 5060 (default) in 3CX System. When I look in the 4 ports in the Patton config, I see that Gateway GW_SIP_0 port is 5060, then Gateway GW_SIP_0 is 5061, 2 is 5062 and 3 is 5063.

    Maybe there is a conflict between sip port 0 5060 and gateway port 5060???

    Thanks!
    Benoit
     
  8. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    421
    Likes Received:
    64
    Just call or email Patton support. They offer free lifetime tech support and will help with issues with Patton device and 3CX.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    Were the highlighted, above, typos? Should the second be GW_SIP_1 ?

    Generally...in a gateway, it can be set-up in a couple of ways depending on the make/model. In some cases 3CX will send calls off to individual ports, such as trunks 1=ports 5060, trunk 2=port 5061, etc. In other cases, 3Cx sends only to one port, such as 5060, and the gateway handles what trunk the call will use (idle trunk), internally.
     
  10. benoit.sauve

    Joined:
    Oct 16, 2015
    Messages:
    13
    Likes Received:
    0
    Hi,

    So Patton helped me. They solved my issue about outbound call very slow but I still have an issue and they asked me to discuss with you.

    I have two analog lines connected to the patton gateway (model 4114, so possibility of 4 analog lines). If first line is occupied (inbound call for example) and we try to make an outbound call, then we got a "busy" line instead of trying on second line. Why? For now, we are able to make outbound calls only if no lines are taken.

    Thanks for your help.

    Benoit
     
  11. optimus1337

    Joined:
    Dec 19, 2015
    Messages:
    6
    Likes Received:
    0
    Can you post the fix that Patton gave you for the slow outbound calls?
     
  12. Zahed Kelani

    Joined:
    Dec 22, 2015
    Messages:
    5
    Likes Received:
    0
    This problem is caused by timeout when 3CX try to use a virtual trunk port that is connected to a patton physical port which is not connected to ISP.

    When you make a new patton gateway in 3CX v12.5- it will assign a virtual port for every physical port in the gateway. So, to solve this problem. Access the web GUI of Patton device and disable the "SIP_GW" interfaces that are assigned to physical ports which are not connected to the ISP. This will make Patton register only to 3CX port that correspond to (ISP connected) patton ports. and you will not face the "timed out" calls which cause delays.

    This method is easy because you just need to check/uncheck the enable checkbox without changing the config file. when you connect additional ISP line to the gateway, simply re-enable the corresponding "SIP-GW" interface so it will register to 3CX.

    Note: This method was used in Patton ISDN gateway. it should be the same for analog. but I didn't try it.

    Note2: 3CX V14 will make only 1 virtual trunk ports now when you configure patton gateways. So, this method will not work.
     
Thread Status:
Not open for further replies.