Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

outbound calls

Discussion in '3CX Phone System - General' started by filipvds, Mar 10, 2014.

Thread Status:
Not open for further replies.
  1. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    Hi,

    we are using 3cx v12 and we are using the softphone (version 12.0.33517.0)

    When we make a call from outlook (for example: +32 3 8233481) the softphone will call a start.

    When we "type" the same number to the softphone, we always get the message "call failed. Destination not found".

    Can somebody help me?

    Filip
     
  2. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    In the previous version there was an option to change +-sign into 00.
    but i cannot find it in the new version.
    can i solve this on the server side?
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,109
    Likes Received:
    329
    I would check the 3CX log to see if the same number is being sent to 3CX in both cases.
     
  4. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    Hi,

    I have to correct my problem!
    Now, when I call a number to +32 38307123 from the softphone or our program, it doesn't work "destination not found".

    In the softphone I've found the setting to change + to 00.
    When I check this option, I still cannot call to this number (same error: destination not found).

    When I take a closer look at the server log of 3CX, I see that he tried to make a connection to "+32 38301234" and not to "0032 38301234").
    So the softphone does not replace the + with 00.

    Can I change this? Or is this a bug?
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,109
    Likes Received:
    329
    In the outbound rules can you not create two, one to deal with a preceding + and one to handle the same numbers, but that start with 00?

    http://www.3cx.com/blog/docs/cid-formatting/
     
  6. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    Hi,

    I will try that tomorrow! But I think it is not a solution.

    Reason: the exact message in the server log is:
    10-Mar-2014 13:47:55.706 [CM503014]: Call(C:254): No known route from Extn:3119 to target: <sip:+323830124@192.168.254.22:5060>
    10-Mar-2014 13:47:55.706 Call(C:254): from Extn:3119 to +3238301234 doesn't match any outbound rule. No outbound rule could be selected.

    I have only one outbound rule.
    Even with this outbound rule, it doesn't work. I think the outbound rule decides which route he will follow. So the outbound formatting on the gateway configuration comes to late.


    Also, when I enable "replace + with 00", I still see the original number +3238301234 in the server log (and not 003238301234).

    Filip
     
  7. fred_gallon

    Joined:
    Nov 28, 2013
    Messages:
    7
    Likes Received:
    0
    outbound rules are applied top-to-bottom ... so make sure your +32 rule is above the others... otherwise it won't be applied.
    I've setup rules for 9 digit Belgian numbers, including the +32, 0032 rules
     
  8. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    Hi,

    I've installed sp4 today. I've created a new outbound rule. I'm sure it is the first one.


    This is the server log:
     

    Attached Files:

  9. filipvds

    Joined:
    Apr 15, 2013
    Messages:
    33
    Likes Received:
    0
    hi,

    we have solved this issue by creating a second outbound rule.
    In this rule we selected all the extension groups, strip no digits and prepend "00".

    until now, this works fine.

    Filip
     
  10. Deepest

    Joined:
    Nov 9, 2012
    Messages:
    45
    Likes Received:
    0
    Hi This is becaue the + symbol is not classified as a didgit by 3cx so if you have a number starting with a +27123456789 and i want to create dialing number 0123456789 your outbound rule should be

    calls to numbers starting with prefix 27
    Strip digits 2
    Prepend 0
     
Thread Status:
Not open for further replies.