Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Outbound Rule for phone number starting with *

Discussion in '3CX Phone System - General' started by atreistm, Aug 10, 2010.

Thread Status:
Not open for further replies.
  1. atreistm

    Joined:
    Aug 10, 2010
    Messages:
    1
    Likes Received:
    0
    Hi,

    I am trying to set up an outbound rule to a PSTN to dial numbers that start with an asterisk, such as *166. I built a rule that captures prefixes starting with *1 , but on my phone I receive error 488, Not acceptable here.

    Could anyne please advise me as to how to set up this rule ?

    Thanks.
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    You cannot set up asterix dialing, it can be sued internally but not to dial out. There is a feature request section should you wish to post it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. vsefcik

    Joined:
    Nov 18, 2009
    Messages:
    19
    Likes Received:
    0
    I have a couple of outbound rules configured for one of our PSTN gateways that enable dialing numbers that start with an asterisk. I'm using a Dialogic DMG2000 gateway to connect 3CX to our business PBX (NEC 2400 IPX) and the NEC PBX uses some access codes that begin with *xx (where xx is a two digit number) to access special outgoing trunk groups. For example, prefixing a number with *82 sends a call from 3CX to the NEC PBX and out a Qwest trunk groupe. Attached is a screen shot of the outbound rule.
     

    Attached Files:

  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    Some gateways (the SPA3102 for certain) don't deal properly with the * or # sent from 3CX. Not sure if your gateway wil do any better, but you can try.

    What you can do, is... select a prefix you don't use, on the PBX, say "5". As a test, create an outbound rule 501 (or whatever number you want). Set "calls to numbers with a length" of to 3, set to strip 3 digits and prepend with *82 (if that is the number you want to send out in the trunk to the NEC PBX). You will not be able to send the prefix and then other digits as there is no way to introduce a pause.
     
  5. vsefcik

    Joined:
    Nov 18, 2009
    Messages:
    19
    Likes Received:
    0
    leejor, I apologize for not being clear in my earlier post on this thread. The outbound rules for the Dialogic gateway that I have configured to route calls from 3CX to the NEC PBX using *82 are working perfectly, as are a couple of other rules that use other *xx access codes in the NEC. I posted my note for atreistm, who was asking how to set up this type of rule. But, thanks for your comments, they may help atreistm.
     
Thread Status:
Not open for further replies.