Outbound Rules Broken In RC2

Discussion in '3CX Phone System - General' started by beaton, May 9, 2011.

Thread Status:
Not open for further replies.
  1. beaton

    Joined:
    Jan 4, 2011
    Messages:
    11
    Likes Received:
    0
    Not sure the outbound rules are working with the latest version of MyPhone (RC2).

    Setup the following rule:

    Numbers starting with =
    Number Length = 7
    Prepend Outbound prefix = 9
    Strip Digits = 0

    Get a "Destination Not Found Message" and you can see that 9 was never appended when dialing a 7 digit phone number.

    I am testing with MyPhone installed locally (with Desktop Components installed) and 3CX Phone v6
     
  2. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Numbers starting with =
    Number Length = 7
    Prepend Outbound prefix = 949
    Strip Digits = 0

    13:19:50.076 [CM503025]: Call(21): Calling VoIPline:1949283xxxx@(Ln.10005@vitel-inbound
    13:19:50.070 [MS210002] C:21.2:Offer provided. Connection(transcoding mode): 76.171.167.121:9022(9023)
    13:19:49.923 [CM503004]: Call(21): Route 1: VoIPline:1949283xxxx@(Ln.10005@vitel-inbound)

    My rules are working fine
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    remove once the local install, clean cache, check here:
    http://www.3cx.com/blog/docs/clearing-browser-silverlight-cache/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. beaton

    Joined:
    Jan 4, 2011
    Messages:
    11
    Likes Received:
    0
    I took the following steps:

    1. Right Clicked on the locally installed App and selected "Remove App"
    2. Uninstalled Desktop Components (using windows XP add remove programs)
    3. Uninstalled 3CXPhone (using windows XP add remove programs)
    4. Manually removed all 3CX Directories in the following paths:

    C:\Documents and Settings\All Users
    C:\Documents and Settings\<My User Account>\Application Data
    C:\Documents and Settings\<My User Account>\Local Settings\Application Data
    C:\Program Files

    5. Cleared IE Cache
    6. Cleared Chrome Cache
    7. Cleared Firefox Cache
    8. Connected to MyPhone via Chrome.
    9. Installed MyPhone Locally
    10. Installed Desktop Components.
    11. Installed 3CXPhone (Auto Provisioned It)
    12. Launched MyPhone Locally
    13. Got Error Message (See Attachment) Clicked Ok
    14. Got Timeout Error...Clicked OK
    15. Deleted All Application Storage for App
    16. Cleared Chrome Cache.
    17. Closed MyPhone And Launched Again
    18. No Errors this time...set up outbound rule (Starts with=<nothing>;Length=7; Prepend=9; strip=0)
    19. Dialed Number and get "Destination Not Found" error logs confirm that 9 was not prepended.

    So am i doing something wrong or is it possible that their might be a problem with the outbound rules in MyPhone? They worked fine on RC1 but they have not worked since upgrading to RC2....I noticed changes where made to the outbound rules as part of the RC2 release...
     

    Attached Files:

  5. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Misunderstanding, I didnt set outbound rules via MyPhone, I only have Outbound Rules set via the admin system.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Hi

    We made a change in this area in RC2. Can you delete the outbound rule you had in myphone and create it again?

    Let me know if this works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Before you delete the rule send me a backup without prompts or voicemails or recordings. Just a backup. Tell me the extension I need to connect too. Send this by email nb@3cx.com

    Then delete the rules and see if this procedure works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.