Outbound rules -- I'm confused

Discussion in '3CX Phone System - General' started by MichaelD, Apr 4, 2010.

Thread Status:
Not open for further replies.
  1. MichaelD

    Joined:
    Mar 27, 2010
    Messages:
    36
    Likes Received:
    0
    I am trying to get the demo 3CX system up and running so I can make sure I like it before buying it and its support plan. In setting up the system, there have been a few things that have not made sense to me, and reading the manual has not helped. I am hoping someone here can point me in the right direction.

    I finally have a one Snom 820 registered in the system using the WLan. By the way, it was a bit of a pain to get it working, but it appears to be fine now. I just need to register the others. But first I am trying to make a call on a particular outside line, and can't seem to figure out how to do that.

    I am using a Patton 4114 FXO interface. It appears that I have it registered correctly in the PBX. It shows up under PSTN devices, as do its 4 FXO ports. Now, I just want to make a call from the extension I set up, and I want it use FXO port 1.

    I looked at the outbound rules, but it appears I can only set a rule to route the call to the Patton box, but not to a particular port on that box. What am I doing wrong?

    MichaelD
     
  2. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,934
    Likes Received:
    250
    You configure a prefix, eg 0, or else a number pattern say number length that identifies an outbound call. In its simplest form its prefix 0 plus the gateway or voip provider you wish to use for the outbound call. This is explained in the manual. You can not specify an individual port, just a gateway by the way.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. MichaelD

    Joined:
    Mar 27, 2010
    Messages:
    36
    Likes Received:
    0
    Yes, I had no trouble with the prefix part. I was just trying to specifically select the FXO port (or group of ports) I want to use for certain outbound calls. This is important because we run more than one business, so we really need the caller ID to show up correctly on the recipient's phone.

    Ultimately, I did figure out how to make a particular extension use a specific FXO port. And it appears I can do the same with a group of phones (but I have not tested that yet). However, it really would be helpful if we could use a dialing prefix (e.g. 92 18005551212) to select the specific outbound FXO port (or group of ports) when making call.

    Any chance of adding that to the list of future enhancements to 3CX? :)

    MichaelD
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,848
    Likes Received:
    299
    If a gateway is capable of routing through a specific port based on a prefix, and i believe some are, then it wouldn't something in 3CX that would prevent you from doing this as you can send out any digits you want to a gateway. It just has to know what you want to do with them. The Outbound Rules allow you a lot of flexibility.
     
  5. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    There is a way but it is not supported by 3CX, im posting this so you may have a solution to your problem.

    First please setup a Patton 4114 as per the guide on the following link >> http://www.3cx.com/voip-gateways/patton-smartnode.html

    Once this has been set up kindly do the following:

    1. Upload the Config to the Device.
    2. DELETE the Device from the 3CX Console > PSTN Devices
    3. Go to 3CX Console > Settings > Provisioning templates > Patton model in question (Firmware R5.x) > Press Edit.
    4. Search for "NumberOfLines" and replace the value of "4" to "1"
    5. Press OK then press OK then press YES.
    6. Click "Add PSTN Gateway"
    7. You will now need to follow http://www.3cx.com/voip-gateways/patton-smartnode.html and repeat this twice, once for each port. When presented with the port number "5060", leave this as is for the first port and set to "5062" for the second port, "5064" for the third port and "5066" for the forth port.
    8. You may wish to revert the change made in steps 3 and 4 above to avoid complications in the future.
    9. You can now setup your outbound rules to address each port individually.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. MichaelD

    Joined:
    Mar 27, 2010
    Messages:
    36
    Likes Received:
    0
    Hey thanks much -- i'll give that a shot.
     
Thread Status:
Not open for further replies.