Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Outbound Rules with '+'

Discussion in '3CX Phone System - General' started by smartek, Dec 4, 2018.

  1. smartek

    Joined:
    Jan 12, 2016
    Messages:
    33
    Likes Received:
    13
    Dear Support & Forum,

    I apologize for this question, as I have found similar topics on this forum but I still can't figure out why it's not working as it should (but I did find a way around this).

    We are in Switzerland. The international phone number is : +41

    If I set only one outbound rule :

    3CX_Outbound_0.jpg
    Calls like 012 345 67 89 & 0041 12 345 67 89 work, but +41 12 345 67 89 will not work.

    I saw that normally E164 Processing Settings should solve this but whatever I configure, I can't make it work. So I have disable everything :

    upload_2018-12-4_16-2-4.png

    And added a new outbound rule :

    upload_2018-12-4_16-3-26.png

    I'm striping one digit (the + sign) and adding 00.

    But there must be a more elegant way to do this ? How am I suppose to configure the E164 Settings, because the default settings are not working.

    Regards,

    Stephane
     

    Attached Files:

  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    The e168 settings will replace the + with an appropriate prefix (that you have specified), you then have to have an outbound rule to deal with (match) that (new) number. If you have calls that are not working, then check the 3CX Activity log. How does the number not working differ from one that does? It probably means that no match is found in the outbound rules (read top to bottom). This may be because you are using rules based on the number of digits sent rather than the prefix(s).

    It may also mean that you have to create more than one outbound rule.
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,358
    Likes Received:
    535
    Hello @smartek

    Enable the E164 settings and add a "0" under the national code field. See if that works.
     
  4. smartek

    Joined:
    Jan 12, 2016
    Messages:
    33
    Likes Received:
    13
    Thank you for your responses.

    That's what i thought but that is exactly why i don't understand. I have ONE outbound rule and the only think I'm checking is if the first digit is 0. So,

    012 345 67 89 (normal local call) works, and 0041 12 345 67 90 (full international format works too) because they both start with 0.

    Now, if the e168 settings does replace the + with the prefix (00, see my picture above), then
    +41 12 345 67 90 should be changed to 0041 12 345 67 90 and therefore my outbound rule should still work ! But it doesnt ...

    With the e168 setting ACTIVATED, if I do a call with the + in front, in the log I see :

    12/07/2018 6:23:00 PM - [Flow] Target endpoint for +41123456789 can not be built!

    So, as suspected, the '+' is not replaced by 00. Any idea why ?
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    Did you set your country code correctly, and specify that if a call matches that, it is to replace the + with a single 0 (national number), and not 00 as would be used on international numbers. Or as dictated by your provider.
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,358
    Likes Received:
    535
    When the PBX detects that you are calling your country it will remote the international prefix and add the national code (if that applies).
     
  7. smartek

    Joined:
    Jan 12, 2016
    Messages:
    33
    Likes Received:
    13
    Hi Leejor,

    Wether it's a single 0 or 00 (I still believe it's 00), I should see in the activity log the '+' replaced by 0 or 00. That is not the case :

    12/07/2018 6:23:00 PM - [Flow] Target endpoint for +41123456789 can not be built!

    So I have the impression that this settings is not working for me (but on multiple different installations).
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    Did you try changing the Log settings to Verbose to see (much) more detail.