Outbound Voip fails

Discussion in '3CX Phone System - General' started by kokoboy, May 4, 2008.

Thread Status:
Not open for further replies.
  1. kokoboy

    May 2, 2008
    Likes Received:
    Hi Gurus,

    I hope you guys can help me out..

    I tested 3CX pabx about 1 months ago, and it all works, with internal and external calls plus receiving.

    So I decided to deploy it for home.

    The strange thing is everything is still configured the same way, but just doesnt work anymore with outbound.

    I got 2 internal soft phones (100, 101) to my 2 pc, and a single server for pabx with all the antivirus and firewall disabled.

    for voip, I have iinet voip account which is tested and works fine with soft phone, as well as an ATA.

    now.. pls keep in mind that I have tested about 1 month ago and it was all working..

    here is my test configurations

    100 <=> 101 (works fine)
    external => 100 (rule based ) works fine

    however, when I call to an outside number it will not work. the busy light for the internal lit up, but will not pickup the voip line to dial out.

    on the server status page, it will just say, it is dailing.. and will not hook to the voip line.

    so.. i tried dailing from my mobile to the voip number and it shows that the line status busy.. and then route to my internal 100 handset.

    So.. i believe the problem with 3cx not passing the initiating sequence to my voip (external) line.

    I have restarted the server, using cmd script, as well as trying on 5060 and 5061.

    the worst thing is it was working about 1 mnths ago.


    Thanks for any support / idea / strong coffees that you guys can send my way.


    ps: here is my LOG

    Time Function Message
    10:40:38.312 Call::Terminate [CM503008]: Call(4): Call is terminated
    10:40:06.390 MediaServerReporting::SetRemoteParty [MS210002] C:4.2:Offer provided. Connection(transcoding mode):
    10:40:06.093 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(4): Calling: VoIPline:150@[Dev:sip:0288472181@sip.nsw.iinet.net.au:5060]
    10:40:05.703 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:00296265374@]
    10:40:05.703 MediaServerReporting::SetRemoteParty [MS210000] C:4.1:Offer received. RTP connection:
    10:40:05.703 CallLeg::setRemoteSdp Remote SDP is set for legC:4.1
    10:40:05.703 Extension::printEndpointInfo [CM505001]: Ext.100: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [NCH Swift Sound Express Talk 3.08] Transport: [sip:]
    10:40:05.687 CallCtrl::eek:nIncomingCall [CM503001]: Call(4): Incoming call from Ext.100 to [sip:00296265374@]
    10:40:05.578 CallLeg::eek:nNewCall [CM500002]: Info on incoming INVITE:
    INVITE sip:00296265374@ SIP/2.0
    Via: SIP/2.0/UDP;rport=5061;branch=z9hG4bK43697344
    Max-Forwards: 20
    Contact: [sip:100@]
    To: [sip:00296265374@]
    From: "win"[sip:100@];tag=4074
    Call-ID: 1209789329-7344-0DBMAX-II@
    CSeq: 892 INVITE
    Proxy-Authorization: Digest username="100",realm="3CXPhoneSystem",nonce="12854335205:e15dc12e20840c6856d50d897c1f7fc4",uri="sip:00296265374@",response="786e3479fd84f4ae6c83d4b263b779f5",opaque="",algorithm=MD5
    Supported: replaces
    User-Agent: NCH Swift Sound Express Talk 3.08
    Content-Length: 0
  2. kokoboy

    May 2, 2008
    Likes Received:
    Wow... Unbeliveable.

    tried for like 3 days none stop to get it going.. it didnt work

    so.. i posted to forum and within 30min got it working.. (no one has replied to my forum request..) lol


    if you guys are in same boat is me.. here is the solution

    change your STUN to an public STUN ip, and suddenly it works.. I am not sure why / what but it works

    looks like some stuff with 3CX stun.. i could be wrong..either case.. i set mine as stun.ideasip.com and it works like a charm..

Thread Status:
Not open for further replies.