Patton M-ATA Disconnects at 32 seconds

Discussion in '3CX Phone System - General' started by fonewiz, Jul 30, 2015.

Thread Status:
Not open for further replies.
  1. fonewiz

    May 13, 2015
    Likes Received:
    I have purchased a few Patton M-ATA FXS adapters for connecting some analog devices. I have experience with other brands and use them without issues on non-3CX installs. I purchased the Patton devices at a higher cost specifically because they are supported by 3CX.

    I have had nothing but trouble, blew most of my day messing with one these.

    I set it up on a new extension and got it to register and send/receive calls OK (I thought). Then I upgraded the firmware on it which removed the option to add STUN settings and broke registration to the 3CX box completely. Took me hours to figure out that was the issue. Once I downgraded the firmware to a slightly older version, my registration worked and I could make/receive calls again.

    I followed the 3CX articles that shows how to set this device up for a fax machine but, shouldn't be any different if I plug an analog phone in.

    Problem right now is that every call I make disconnects at exactly 32 seconds. This M-ATA is located on my home network and connects out o a public IP on the 3CX server. I do not really suspect my network or home router/firewall because I have several IP phones connecting to different servers with no issues including the same 3CX server I am trying to get this Patton to work on.

    I am at a loss, I have configured and used many ATA's over the years but I am stumped on this one. I find it odd that there are really very few configuration options in the Patton device in comparison to any other ATA I have used in the past. Some of the other settings are just downright confusing in my opinion and not what I have seen in other ATAs. Considering these cost me 3 times as much a similar Grandstream which always work well for me, I am not impressed so far.

    I am likely going to contact Patton tomorrow to see what they have to say but I thought I would throw this out on the forum here and see what others have experienced. I have searched Google and this forum until I am blue in the face but nothing has really helped. Thanks in advance for any suggestions.
  2. lneblett

    lneblett Well-Known Member

    Sep 7, 2010
    Likes Received:
    Do a search for 32 seconds as you are not the only one who has come across this. While I do not think any relate directly to the M-ATA, it is likely a router issue whose solution may be in the other posts.

    Manufacturers' implementation of various features may not always function equally well across the board. I have used the M-ATA without any issue, but like you, I don't know that its higher price point provides any performance enhancements over many of its competitors. They do however, have excellent gateways and PRI interfaces and their support is equally good.
  3. leejor

    leejor Well-Known Member

    Jan 22, 2008
    Likes Received:
    Have a look a the 3CX logs, for one of the calls. 30ish seconds is the time-out period (call drops) when there is no ACK received. You may have a network settings that needs "tweaking".

    On a side note, I had this happen recently, on a Win 7 Pro system (32 bit), running version 12. All incoming VoIP trunk calls dropped at about 30 seconds with no ACK received. The PC had not been re-booted in a while (at least 6 months), and that is what it took to fix the issue.

    Other things to consider... how many SIP devices do you have working on your home network? If more than a couple, are you using the 3CX SBC? If not, were unique local port numbers assigned to each ATA? What make/model router are you using at home? Some have a SIP/ALG option that may require "adjustment". Have you tried using the same ATA at another location? If the disconnect doesn't happen there, then I'd say it's your home network (router?).
  4. Anonymous

    Anonymous Guest

    That sounds like it could be a NAT configuration issue on the M-ATA also. I've got a number of M-ATAs on 3CX installs without any issues. Assuming you are using the M-ATAs on the same network, try going into Telephony>SIP>NAT Traversal and set it to NONE.
Thread Status:
Not open for further replies.