Patton Smartnode 4114 Error

Discussion in '3CX Phone System - General' started by brentrichburg, Apr 26, 2011.

Thread Status:
Not open for further replies.
  1. brentrichburg

    Joined:
    Nov 16, 2010
    Messages:
    30
    Likes Received:
    0
    I get the following email error on an outbound call.
    _______________________________
    (0) TC-3CX 4/25/2011 7:06:46 PM
    Call to 97740146@(Ln.10000@Patton 1) has failed. [ V4 10.9.27.251:5060 UDP target domain=unspecified mFlowKey=820 ] replied: 502 Bad Gateway; from IP:10.9.27.251:5060
    _____________________________________
    Here is the corresponding log entry
    _______________________________________________
    19:06:50.004 [CM505002]: Gateway:[Patton 1] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Patton SN4114 JO EUI 00A0BA0605A5 R5.3 2009-01-15 H323 SIP FXS FXO M5T SIP Stack/4.0.28.28] PBX contact: [sip:10001@10.9.25.82:5060]
    _______________________________________________

    The call does connect correctly on the port that it says has failed, however I get an error email every single time that route is used. Inbound calls generate no errors.

    Any suggestions?
     
  2. Josh Gurkin

    Joined:
    Aug 15, 2012
    Messages:
    2
    Likes Received:
    0
    Bump. I have just begun to experience this same error.
     
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Come now, the same? The first post is over a year old and while you may have the same symptom, it may not be caused by the same underlying issues.

    Need more detail about setup.
    How many ports are in use, are all available for outbound? Were any other calls in progress at the same time (either in or out). What version 3CX and how many sim calls supported? What rules are in place? Is this is a new install, or is it one that has been around for awhile and this just started. Do all the ports show as registered? How about some logs showing what 3CX thinks and preferably more that one line like the first poster showed?
     
  4. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Contact Patton support it looks to be a gateway problem, as the log says bad gateway.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Josh Gurkin

    Joined:
    Aug 15, 2012
    Messages:
    2
    Likes Received:
    0
    The problem is identical. This system has been running for about 8 months. The system has 32 sim calls. All ports were available. This gateway has 4 lines all connected. The only rule affecting this call is to use the Patton.

    Email
    Call to XXXXXXXXXX@(Ln.10003@Patton-1) has failed. [ V4 192.168.2.12:5060 UDP target domain=unspecified mFlowKey=820 ] replied: 502 Bad Gateway; from IP:192.168.2.12:5060

    Log
    08:37:40.897 [CM505002]: Gateway:[Patton-1] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Patton SN4114 JO EUI 00A0BA06FB94 R6.1 2012-05-09 H323 SIP FXS FXO M5T SIP Stack/4.0.30.30] PBX contact: [sip:10000@192.168.2.11:5060]

    I told you it was the same error. I had already checked the logs. The only difference is the Serial Number/MAC of the Device and firmware versions.
     
  6. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    OK, got it and my apologies. I try and answer many questions on the forum and the number of folks who say "I have exactly the same problem" where it may be the same problem, but not the same cause/effect or set-up is quite frequent. I can only ask for more detail in the hopes that I might be able to spot something that could be the root cause.

    In your case, I don't see any such indication. I can only offer that a reboot of the appliance might bring it back, but failing that it looks like a call to Patton is in order.
     
  7. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Have you checked to see if the firmware on the gateway is the most recent release?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.