PBX Server Not Reachable

Discussion in '3CX Phone System - General' started by figtree, Nov 2, 2009.

Thread Status:
Not open for further replies.
  1. figtree

    Joined:
    Nov 2, 2009
    Messages:
    6
    Likes Received:
    0
    I'm trying to connect my 3CX-PBX with the 3CX-Gateway-Skype but are on different PC's on each other.
    When I tried connecting them on the same PC, all is working fine. Outbound call and Inbound were okay.

    But when I put them to separate PC's with different IP addresses (same LAN), it seems that the PBX is ignoring the SIP register messages from the Skype-Gateway.

    I have checked the config on my PBX, it seems alright. But I can only see the SIP-Registrations from the Skype-Gateway being received by the PBX. The PBX is not responding with any SIP messages. I just can't connect with the Skype-Gateway.

    On the same PC's, all were fine.

    What could be wrong? Appreciate your advise.


    Thanks,
    Fred
     
  2. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Hi, can you please take a capture and send it to me at mb@3cx.com. Probably there is something wrong in the configuration or ports.

    Hope you did not leave the 3CX Skype gateway port in the 3CX management console to 127.0.0.1 correct?

    If you changed the location (ip) of the skype gateway you have to also change (or create) a new Skype GATEWAY line in the 3CX Add Ports section pointing this to the proper (NEW) Skype gateway IP AND PORT.

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. figtree

    Joined:
    Nov 2, 2009
    Messages:
    6
    Likes Received:
    0
    Hi! Michael,

    I sent you a mail at mb@3cx.com;

    In the gateway settings (on the PBX-3CX), I put the following;
    Gateway IP or Hostname: 192.168.150.249 (IP of the Skype-Gateway)
    Gateway Port: 6060 (port in Skype-Gateway)

    Port ID: 10000 (Same as in Skype-Gateway)
    Authentication ID/ Password: 10000 (Same as in Skype-Gateway)

    I'm receiving the sip packets (traces taken at the PBX-3CX side) from the Skype-Gateway (192.168.150.249), but it seems the PBX is ignoring, or discarding these sip requests.

    Thanks on looking on this issue.

    -Fred
     
  4. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Hi Fred,
    The firewall test is not related.
    You do not need stun translation or check you NAT between the local machines (.249 and .163)

    It is very simple - This was working and the moment you removed the skype gateway from the same machine it stopped working. You have to have some firewall on blocking the incoming requests.

    Restart the 3CX Phone system service.
    Stop the skype gateway -
    Check the configuration of the skype gateway and confirm that the file / settings / Advanced and the option PBX sip port points to the correct sip port - 5060

    Go to Right click on the gateway port in Skype and you have an option - Tracelog - send that to us. This is important.

    it is also another option to delete the gateway port IN 3CX and re-create it again.

    Also from where was this capture taken? from the PBX host or from the gateway host?

    Also if you want you can download latest skype gateway from the following link, http://www.3cx.com/downloads/v8/3CXGatewayforSkype_2.9769.msi
    Uninstall old version and install latest version (9769). Please send me feedback on mb@3cx.com

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. figtree

    Joined:
    Nov 2, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks so much Michael.
    It is just an issue on my firewall. I was able to register the Skype-GW to the PBX (another PC) successfully.

    Thanks!

    regards,
    Fred
     
Thread Status:
Not open for further replies.