Performance of Web Management Console

Discussion in '3CX Phone System - General' started by Frank D, Feb 10, 2016.

Thread Status:
Not open for further replies.
  1. Frank D

    Frank D New Member

    Joined:
    Oct 6, 2014
    Messages:
    215
    Likes Received:
    6
    Hi,

    I have an issue with the performance of the Web Management Console of 3cx.
    I access the system via remote Desktop using Firefox to access the localhost http: //localhost:5000/management/MainForm.wgx
    We are running V12 SP 6.2.

    The CPU use of the system, normally being around 10% jumps to 70%, sometimes hitting 100% . Especially when I access "phones". I can see the spinning wheel inside the browser and it spinning coincides with the time the CPU usage goes up.
    The taskmanager tells me, Firefox is using about 50% of the CPU in these time and about 180 MB memory. I have just one tab in Firefox open. Working with the managing console this way is a little frustrating, as I have to wait several seconds after clicking on the menu, till the new site shows up. And I am afraid Firefox may slow the telephone system itself down.

    We are running the Windows 2008 Server as a virtual machine, with lost of resources allocated on powerfull hardware. I will add some more details later, but I think we got 26 GB of RAM and 2 CPUs allocated at the moment.
    There are 300 phones connected, but not many calls.

    I just checked the same behaviour with IE as with Firefox (Firefox ESR 38.6.0).

    Is the above described performance of the 3cx-management-website normal? What are you experiencing? Or may there be some misconfiguration of our system? What are common mistakes configuring the Browser and the webserver?

    Best regards Frank
     
  2. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    I'm also experiencing same problem, even adding significant resources to VM. Same in V.14, I haven't tested with SP2.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Frank D

    Frank D New Member

    Joined:
    Oct 6, 2014
    Messages:
    215
    Likes Received:
    6
    If I access the webinterface remotely via the browser of a second PC I get a similar behaviour. CPU usage of the PC goes up. Other websites load fine.
    My PC is not the most powerfull machine.
     
Thread Status:
Not open for further replies.