Phone Firmware Provisioning Snom

Discussion in '3CX Phone System - General' started by claxtro, Sep 7, 2011.

Thread Status:
Not open for further replies.
  1. claxtro

    Joined:
    Mar 12, 2011
    Messages:
    22
    Likes Received:
    0
    Have a question on provisioning of firmware for the Snom phones. Provisioning of settings works great, firmware I am having some issue. I have the bin file in C:\ProgramData\3CX\Data\Http\Interface\provisioning\firmware\snom but it's looking for the snom821.xml file and I am unable to locate it. See error log below from Snom. Please advise.

    Fetching FW URL: 172.20.x.x:5000/provisioning/firmware/snom/firmware821.xml done, result 404

    --Rob
    StarTribune
     
  2. madigan

    Joined:
    Nov 10, 2010
    Messages:
    6
    Likes Received:
    0
    Hi Rob,

    that's correct behaviour. It's not possible to point to the bin file directly.
    In you case you would need to create an xml file named firmware821.xml and store it in the same folder.
    The file should look like this:

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <firmware-settings>
    <firmware perm="">172.20.x.x:5000/provisioning/firmware/snom/[name of bin file]</firmware>
    </firmware-settings>
    Good luck!
    madigan
     
  3. claxtro

    Joined:
    Mar 12, 2011
    Messages:
    22
    Likes Received:
    0
    Thanks Madigan.
    Yes, that did the work. What I found though is we need the http:// at the beginning in the XML file to make it work. So a phone is plugged in for the first time, downloads the settings which prompts the Snom phone to look for the updated firmware and starts updating automatically! The only thing is the time it takes for first time deployments which can be up to 10 minutes as the phone first goes through its initial bootup,then firmware upgrade. Thanks again.

    --Rob.

    <firmware perm="">http://172.20.x.x:5000/provisioning/firmware/snom/[name of bin file]</firmware>
     
  4. madigan

    Joined:
    Nov 10, 2010
    Messages:
    6
    Likes Received:
    0
    Sorry, Rob. Of course http:// is required. I just accidentally removed it when pasting your IP in the example link ;)
    However, I'm glad you could sort that out..

    madigan
     
Thread Status:
Not open for further replies.