Phone Quality Issues

Discussion in '3CX Phone System - General' started by Hitesh Patel, Aug 17, 2017.

Thread Status:
Not open for further replies.
  1. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    Hi. we have a 3cx system here and we have a 100mb/100mb internet speed and a sonicwall..
    we are having issues with phone quality where sometimes the quality doesn't allow you to understand the person on the other end..

    i have run a speed test and it get 90mb up and 90mb down.

    anyone know how to resolve this issue

    thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Please provide a bit more information about the set up. All on the same LAN? What type of sets? Is this affecting only outside calls or internal calls as well? have you run a latency test at all?
     
  3. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    All the phones are on the same LAN most of the user use the 3cx softphone not a actual phone. we dont make alot of internal calls mostly all the calls are external. any recommeded Latency test you think i should run?
     
  4. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    here is a Latency i test from a website:

    Packets Lost: None
    Latency: 93.331ms
    Jitter: 4ms
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Results seem acceptable. How are internal calls? Any issue at all? You say most users use the softphone. Do the users that don't, have the same issue? Did this issue just start, or has it been ongoing from day one? Are all external calls over one provider/route?
     
  6. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    never really tested internal calls.. users without softphones also have a issues as well and this issue has been going on for awhile now and all the calls go over the same network and WAN.. currently we are on version 12 and i am looking to upgrade to version 15 since there is a new codec available in that version that i am hoping can resolve the phone quality issue
     
  7. AlexDBarrett

    Joined:
    Jan 25, 2011
    Messages:
    71
    Likes Received:
    9
    SIP ALG turned off on your firewall?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    So...it wasn't this way originally? What changed about that time? New hardware (switch) on the network?
     
  9. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    apparently it has always been like this for as long as i have been here which is a year now..i will check the firewall.. we use a sonicwall
     
  10. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    so SIP Consistant NAT is disabled on my sonicwall.. should that be enabled?
     
  11. daneke

    Joined:
    May 8, 2017
    Messages:
    46
    Likes Received:
    4
    What are you doing on your LAN besides phone? How many users? You can get a decent POE Netgear 24 port GigE switch for $250.
     
  12. Hitesh Patel

    Joined:
    Aug 17, 2017
    Messages:
    11
    Likes Received:
    0
    we have about 80 users.. on the LAN we have users connected to sql servers alot and copying and moving backup files around
     
  13. daneke

    Joined:
    May 8, 2017
    Messages:
    46
    Likes Received:
    4
    That's traffic.
    $1000 you have 4 GigE switches and QOS. I think the network is killing the audio, but I could be wrong.

    Those switches also look for loops, bad cabling, and crc errors.
     
  14. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    While it certainly could be a switch issue, I would first suggest running a packet capture on the 3CX Server to get a call that has bad audio, then check if the audio is arriving 'broken' from the Provider side or if it being transmitted onto the network fine, which would then imply something wring with the switches.

    Although I know you said you don't do internal calls, that would be a pretty good way of checking if the switches may be at fault or not.
     
  15. OCWI

    OCWI New Member

    Joined:
    Jan 17, 2017
    Messages:
    160
    Likes Received:
    46
    consistant nat on sonicwall and QoS the SBC or PBX
     
Thread Status:
Not open for further replies.