phone takes too long to ring with inbound calls

Discussion in '3CX Phone System - General' started by resqadmin, Apr 8, 2009.

Thread Status:
Not open for further replies.
  1. resqadmin

    Joined:
    Apr 8, 2009
    Messages:
    2
    Likes Received:
    0
    Good Day everyone, I've listed details of my problem below
    please help

    Equipment :-
    SNOM M3 Base & Handsets
    Grandstream GXW-4108 PSTN Gateway
    3CX PBX Server

    When I dial into the pbx from an external number eg. my mobile
    1) I can see the pbx trunk line connecting the incoming call
    2) I'm hearing the phone ringing on my mobile
    3) there is no ring internally at the extension until after the 10th ring on my mobile
    4) once the phone is answered internally the call connects fine.


    Similarly,when making outbound calls, there is a 2-3 second silence before I can hear a ring. The call goes through fine.

    Has anyone experienced this or does anyone know what could be causing this? Any help greatly appreciated.

    ZiGGZ
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,723
    Likes Received:
    274
    There are settings on most ATA's to allow for a delay before answering an incoming call. If set too low (at least in North America0 you won't get the caller ID passed on to the 3CX, 3 seconds seems to be about the minimum for that to work. Check that it isn't set to 10 seconds on your ATA.

    Do you have a dial plan built on the phone? Most sets or ATA's will wait a few seconds to be sure your aren't dialling any more digits before sending them all to the SIP server. Five seconds is normally the default. If you build a dialplan then you can force the phone to send digits immediately once you have dialled a certain pattern or number of digits.
     
Thread Status:
Not open for further replies.