Phonebook not loading with CallCentric

Discussion in 'Windows' started by gpsjeff717, May 3, 2010.

Thread Status:
Not open for further replies.
  1. gpsjeff717

    Jun 5, 2008
    Likes Received:
    I have just yesterday downloaded the latest version of the 3CX VoIP Phone - Version 4.0.10858.0
    I'm using it on Windows XP SP3

    I am testing it as a standalone SIP softphone with CallCentric.
    Everything seems to work fine as far as making and receiving calls.

    The problem I am having is when I create a phonebook and populate a few names and numbers.
    It works fine while the phone is still loaded and running.

    The problem arises when I shut-down the softphone, wait a few moments, and then restart the phone.
    Now, when I go back to the Phonebook, there are no entries.... no phonebook has loaded?

    I restart the softphone a half-dozen times, make a couple configuration checks. On seemingly random number of restarts, the phonebook is magically back and readable? But, more often than not, next time I restart the phone, the phonebook is gone again.

    I have checked that the .ini phonebook files have been created and saved in the Phonebook Contacts and Phones folders:

    C:\Documents and Settings\Jeff\Local Settings\Application Data\3CX VoIP Phone\Phonebook\Contacts\contacts204.11.192.35.ini
    C:\Documents and Settings\Jeff\Local Settings\Application Data\3CX VoIP Phone\Phonebook\Phones\phones204.11.192.35.ini

    It just seems like it isn't reading the .ini files properly.
    Anyone else had this problem?
    Any solution?
    Or, is it a bug waiting to be fixed?
  2. gpsjeff717

    Jun 5, 2008
    Likes Received:
    Re: Phonebook not loading

    I have solved the mystery of the missing phonebooks...

    Thanks to a discussion in this post:
    I discovered the following:

    What I found:
    I Always register my ATA's and softphones using "" as the "domain name" and "proxy name" instead of using their IP address. I was puzzled by the IP address appended to the Contacts and Phones .ini files names. At first I didn't make the connection to CallCentrics IP address (I never use their IP address).

    What I discovered was that uses about 9 different servers with different IP address. When the domain or proxy name is translated from to the proxy IP address is uses one of the 9 available IP addresses. When I login and CallCentric translates to a different IP address, then it appears that the 3CXPhone is looking for an Contact and Phone list that is appended with that IP address. Well, those different IP's don't exist because I didn't create a phonebook under that IP name..... very confusing.... but now I get what's going on.

    I guess the 3CXPhone is always assuming that the IP-PBX or VoIP proxy it is registering with is always using the same IP address... However, when registering the softphone using domain names instead of IP addresses, the IP address translation is not always the same (multiple servers for load balancing?) and thus the phone book can't be found when the IP address of the domain name translates to different IP address...

    Unfortunately for me, CallCentric calls don't work if I register with one of the server IP addresses directly.... I have to register with "". Calls work fine registering with the domain name..... 3CXPhone phonebook just doesn't work then..... :cry:
  3. gpsjeff717

    Jun 5, 2008
    Likes Received:
    It would be nice if 3CX would fix the 3CXPhone phonebook file name convention to not depend on the IP address of the VoIP proxy logged into. This creates a problem when using services like CallCentric and essentially renders the phonebook feature useless.

    I contacted CallCentric on this issue. They confirmed that they require users to register with their service using only "" and not IP addresses. This is because they distribute assignment requests to any of their 9 proxy servers for "load balancing" purposes. That's just how they do it.

    So, in order to get the 3CXPhone softphone to work with CallCentric as a stand alone VoIP service, it is necessary to register with domain and proxy, not an IP address.

    Here is the not so elegant solution I implemented (which is also what CallCentric recommended).

    1. Create your 3CXphone phonebook while registered with
    2. Pre-populate the phone book with as many contacts and phone numbers as you expect to be using.
    3. Close the 3CXPhone app.
    4. Find the 3CXPhone phonebook folder on your PC.
    "C:\Documents and Settings\YourUserName\Local Settings\Application Data\3CX VoIP Phone"
    5. Inside the Phonebook folder, open the "Contacts" folder and find your recently created CallCentric "contacts" .ini file:
    "C:\Documents and Settings\YourUserName\Local Settings\Application Data\3CX VoIP Phone\Phonebook\Contacts"
    It will be using one of 9 possible IP addresses used by CallCentric.
    i.e. "contacts204.11.192.31.ini"
    6. Copy this file 8 times in this folder for a total of 9 files.
    7. Rename these copies to reflect each of the 9 possible remaining proxy server IP addresses:

    8. Now, navigate to the "Phones" folder:
    "C:\Documents and Settings\YourUserName\Local Settings\Application Data\3CX VoIP Phone\Phonebook\Phones"
    9. Note the IP address of the Phones .ini file. The IP address will be the same as you noted in the Contacts folder.
    10 Copy this file 8 times, just as you did with the Contacts .ini files.
    11. Rename these copies to reflect each of the 9 possible proxy server IP addresses:

    12. Now, you can restart the 3CXPhone and when it loads, it will likely register with a different IP address as the first time you created the phonebook. But, now because you have 9 copies of the phonebook files, the 3CXPhone will open one that matches the IP address of the currently registered proxy server.

    Not an elegant solution, but perhaps the only solution to get the 3CXPhone phonebook to work with CallCentric.... until 3CX redesigns the phonebook file system for the softphone...
  4. micale

    Oct 31, 2011
    Likes Received:
    I had the same proble. But thanks to your posts I could find the solution to my problem. It works fine now!!! cialis
Thread Status:
Not open for further replies.