Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Phones Don't Ring When In Call Queue

Discussion in '3CX Phone System - General' started by ntnetzeband, Sep 23, 2016.

Thread Status:
Not open for further replies.
  1. ntnetzeband

    Joined:
    Jul 30, 2016
    Messages:
    65
    Likes Received:
    5
    Hello,

    We are facing an issue where our phones in a queue don't ring when the queue is called either internally or externally. We think we have found how to reproduce what causes the issue:

    1) External calls come in to queue
    2) Employee answers call and employee hangs up the call when done talking
    3) External/Internal call comes into queue and the above phone doesn't ring at all, either on the 3CX application or the physical IP phone

    The extension can be dialed directly but the only way for the call to go through in the queue, you have to remove and add the extension back to the queue. We use a ring all for these call queues so all phones should ring at once but they are not.

    Has anyone faced this issue and if so, what did they do to fix it?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    When "step 1' happens, did the user just log into the queue?

    What is the status of the set just after hang up? Does it show they are unavailable, or logged out?

    Are there any error , or helpful messages in the 3CX log?
     
  3. ntnetzeband

    Joined:
    Jul 30, 2016
    Messages:
    65
    Likes Received:
    5
    No, it just started happening yesterday and we have all been logged into the queue for months. We all show available and logged in and even rebooting the phone doesn't work. The only fix we can find is to remove from the queue and then add it back in.

    Everything works fine, it just looks like the phones are hanging somewhere and not letting 3CX know that they are off the call.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    have you confirmed, in the log, that there is a "Bye" at the end of the working call and that the extension status in the PBX then shows as idle?

    Was anything changed on the network/PBX/sets/firmware ?

    Have you re-started, either the PBX, or the server?
     
Thread Status:
Not open for further replies.