Phones not getting correct time

Discussion in '3CX Phone System - General' started by TSlocum, Oct 6, 2015.

Thread Status:
Not open for further replies.
  1. TSlocum

    TSlocum New Member

    Joined:
    Oct 15, 2013
    Messages:
    225
    Likes Received:
    15
    We've got Cisco SPA514g phones and when they auto-provision with DHCP Option 66, they don't get the correct time. They show 1/1 12am. The time on the server is correct and the time zone is set correctly in the provisioning options.

    What could be causing this?
     
  2. empower1

    Joined:
    Aug 2, 2010
    Messages:
    2
    Likes Received:
    0
    We were having the same issue but I found the resolution

    Assuming your phone is provisioned with the right Provisioning Template, do the following:

    3CX Phone System - Settings - Phone Provisioning
    Enable Day Light Savings Time


    I am in Australia, so these are my StartTime and EndTime

    StartTime: Month: 10 - Day: 4 - Hour: 0
    EndTime: Month: 4 - Day: 3 - Hour: 0
    Offset(Minutes): 60


    Save the settings and re-provision your phone from

    3CX Phone System - Phones - Re-provision Phone

    Good luck
     
  3. TSlocum

    TSlocum New Member

    Joined:
    Oct 15, 2013
    Messages:
    225
    Likes Received:
    15
    I tried that and it didn't work.
     
  4. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    298
    Likes Received:
    30
    Check the management console
    Settings
    Phone Provisioning
    Time Settings
    Time Server

    default is
    pool.ntp.org

    This should be provisioned and be visible in the phone web interface and this is where the time should be coming from, along with your time zone modification and dst. If you are not getting a good date then you are probably not getting to a good time server.

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. TSlocum

    TSlocum New Member

    Joined:
    Oct 15, 2013
    Messages:
    225
    Likes Received:
    15
    I've tried pool.ntp.org, 0.us.pool.ntp.org (another ntp pool server here in the US), and the local DC, none of which work.
     
  6. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    298
    Likes Received:
    30
    Might want to examine your firewall(s) to make sure they are not blocking ntp traffic.

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. stalley

    Joined:
    Oct 8, 2015
    Messages:
    16
    Likes Received:
    2
    My Cisco 7960s would never pull the time info from 3cx server (v12). I had to hard code it in their template, which seems to be working fine now. You phones are much newer than mine, but this is what worked for me...

    #Setting for Timezone and DST, Option GMT,CET,EET,...
    sntp_server: "10.10.10.65" (internal ntp server)
    sntp_mode: unicast
    time_zone: "%%param::time_timezone_cisco79x0%%"
    dst_offset: 1
    dst_start_month: March
    dst_start_day_of_week: Sun
    dst_start_week_of_month: 2
    dst_start_time: 02
    dst_stop_month: Nov
    dst_stop_day_of_week: Sun
    dst_stop_week_of_month: 1
    dst_stop_time: 02
    dst_auto_adjust: 1
    time_format_24hr: 0
    date_format : M/D/Y
     
  8. efounco

    efounco New Member

    Joined:
    Sep 28, 2011
    Messages:
    148
    Likes Received:
    4
    First off, make sure NTP is defined and setup properly in the DHCP server settings. Next, use an internal NTP server versus a pool/public NTP server. Some phone are picky about resolving to external pool/public NTP servers through a firewall. Try using the IP address instead of the FQDN. This will eliminate any DNS issues you might have. Finally, don't use the 3CX out-of-the-box provisioning template for your phones. You can create a custom value that changes your daylight savings time without the need for micromanagement. For instance, we use (with our SPA504G):

    <Daylight_Saving_Time_Rule group="Regional/Miscellaneous">start=3/8/7/02:0:0;end=11/1/7/02:0:0;save=1</Daylight_Saving_Time_Rule>

    This setting adjusts the time changes automatically without the need of defining them every year in 3CX.
     
Thread Status:
Not open for further replies.