In Progress Please Enable SRTP or Secure SIP in 15.5 Linux Version

Discussion in 'Ideas' started by msnyder, Sep 8, 2017.

In Progress Please Enable SRTP or Secure SIP in 15.5 Linux Version 5 5 7votes
5/5, 7 votes

  1. msnyder

    Joined:
    Jul 20, 2017
    Messages:
    24
    Likes Received:
    3
    This would be very helpful and won't require us to re-deploy using Windows version.
     
    ITW likes this.
  2. coreybrett81

    Joined:
    Nov 11, 2016
    Messages:
    51
    Likes Received:
    7
    Seems like full encryption should be the default for new installs these days. TLS for SIP and SRTP should be the norm. Let's Encrypt is already in place for the web interface, why not use it for the call legs too.
     
  3. Richard Smith

    Joined:
    Sep 1, 2017
    Messages:
    1
    Likes Received:
    0
    Me too! Need Linux secure SIP.
     
  4. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,926
    Likes Received:
    241
    It does but not automatically. We are working on it
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Silly English Kniggit and the60 like this.
  5. Silly English Kniggit

    Joined:
    Sep 13, 2017
    Messages:
    220
    Likes Received:
    84
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Steven Fletcher

    Joined:
    Nov 15, 2017
    Messages:
    1
    Likes Received:
    0
    +1 for this - ideally by linking in with the existing Let's Encrypt certificate that is used on the webserver.
    .. and also, SIP-TLS / SRTP or some sort of TLS for the 3CX clients (Android/IOS/Windows etc) which use tunnelled connections.