Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Polycom 501 w v14

Discussion in '3CX Phone System - General' started by PatrickTodd, Jan 16, 2016.

Thread Status:
Not open for further replies.
  1. PatrickTodd

    Joined:
    Jan 12, 2016
    Messages:
    40
    Likes Received:
    6
    I have a few Polycom Soundpoint 501's that still are functional (about 15 or so in the back) and would like to use them

    I have provisioned them using Option 66 with my internal provisioning link (which by the way is not where the current DOC [http://www.3cx.com/sip-phones/dhcp-option-66/] lists it, might want to update that documentation, so far as I can find, it only lists the external prov link on the startpage..)

    So far so good, phone I have added can call other extensions and can call out etc.
    I see the phone is not officially supported, but a provisioning file exists already called Polycom SPIP (3.1.X) so I figured all would be well.

    One pretty major issue, no button tone sounds whatsoever, no dialtone, no ringing while dialing.
    The only real thing I am concerned about is the button tones, you can't make any selections if you hit an IVR if you can't tone.

    I am certainly not a pro at this level of config for phones, can anyone point me in the right direction to what I can/should change or have a working provisioning file I can edit? The actual version of the phone is 3.1.3

    I attempted to upload what I see in the default prov file, but it was blocked as a 'possible attack vector', hahah.
     
  2. PatrickTodd

    Joined:
    Jan 12, 2016
    Messages:
    40
    Likes Received:
    6
    Re: Polycom 501 w v14 - DTMF?

    Through some reading (http://www.3cx.com/blog/voip-howto/dtmf-rfc2833/) I realized this is related to DTMF settings? Were there changes to how this is configured in the provisioning file from older versions of 3CX?
     
  3. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,375
    Likes Received:
    84
    Even though you do not hear the DTMF Tones, they may be transmitted from the phone. The only way I can think of is to run Wireshark on the server and make a call, the filter in Wireshark by typing 'rtpevent' and see if any packets show up.

    As far as I can recall the templates should be OK.
     
  4. PatrickTodd

    Joined:
    Jan 12, 2016
    Messages:
    40
    Likes Received:
    6
    I don't see anything in wireshark for that so I don't think the phone is sending anything via the 101 payload type.
    Also to note, the phone does not ring when called, it shows a call, but makes no noise, does not seem like some of the buttons are configured either.

    I went ahead and placed updated bootrom and sip.ld files with the model name in the provisioning folder and was able to successfully update the phones to 3.1.8 (the last version usable by the 501's) and still have the same issue.

    Other items like the 3CX Softphone and the Unifi UVP phones work just fine and send tones, but I am not sure that works the same way.


    I checked the config and it is set to use RFC2833 and tone.dtmf.viaRtp="1"
    It looks like it is provisioned the same way my old asterisk system had configured but for some reason now is not working with 3CX.
    Should I try a different payload type such as 127?


    Additionally, I am not seeing codec selection when editing the extension from the 3CX gui, should that be populated?



    I am trying to reference here http://community.polycom.com/t5/VoIP/FAQ-Phone-unable-to-send-DTMF-to-an-IVR-system-or-how-to/td-p/4237


    But I am having trouble understanding; I will keep trying, any help is more than appreciated. :D
     
Thread Status:
Not open for further replies.