Polycom 6000 conference phone auto-provision

Discussion in '3CX Phone System - General' started by fonewiz, Jan 6, 2016.

Thread Status:
Not open for further replies.
  1. fonewiz

    Joined:
    May 13, 2015
    Messages:
    44
    Likes Received:
    0
    I am having all sorts of trouble with a Polycom IP 6000 conference phone, long story. I want to use the auto-provisioning method and see if that somehow helps.

    I have tried to follow the instructions here, but they are not clear in my opinion:
    http://www.3cx.com/sip-phones/polycom-soundstation-5000-6000-7000/

    It mentions that I should "Install" the firmware by downloading the Zip file, unzipping and placing the contents in the directory mentioned. But, do I place the folder there or just the files in the folder? Is it certain that they go in the root of the folder mentioned or do they need to go in the folder labeled "Firmware". It's very confusing.

    Also, how do you then upgrade the firmware on the device?

    Finally, and here is the biggest issue at the moment.. It says to then go to the extension and to the provisioning tab, select the phone model from the drop down.. Well, the model isn't in the list, in fact, no Polycom models are in the list. So, where do I go from there?

    Thanks in advance for any help..
     
  2. fonewiz

    Joined:
    May 13, 2015
    Messages:
    44
    Likes Received:
    0
    Related post: http://www.3cx.com/forums/topic43763.html
     
  3. snowsam

    Joined:
    May 26, 2011
    Messages:
    79
    Likes Received:
    0
    We are using the Polycom 5000, autoprovisioned from 3CX, with no issues. Assuming your templates included in your 3CX install are up to date you pick the brand a phone and then pick the model.

    The firmware upgrade can be a manual process via the web interface and via the autoprovisioning (option 66) .

    You unzip the contents of the zip file into your provisioning folder.

    But that is not enough...

    However, on my 12.5 server, it says:
    " Polycom - Phones only check for firmware from the path where they get the provisioning file. This means that you need to place firmware in the Provisioning folder NOT in firmware folder.
    Language packs - Languages should be taken from the COMBINED or SPLIT firmware download from polycom's website and the whole folder named "SoundPointIPLocalization" should be placed in the provisioning"

    I think the note about the " SoundPointIPLocalization" folder should be added to the web page, or the 407.zip should be modified to include that folder. I just got mine from the 4.0.9 release: http://support.polycom.com/PolycomService/support/us/support/voice/polycom_uc/polycom_uc_software_release.html#4.0.9


    ** Hey 3CX ** how about updating the page at http://www.3cx.com/sip-phones/polycom-soundstation-5000-6000-7000/ ?
     
  4. fonewiz

    Joined:
    May 13, 2015
    Messages:
    44
    Likes Received:
    0
    Thanks, I will read over your response carefully and see if I can make some headway. I am running Version 12 not 12.5 and I can't update the install just yet, it's a multi-tenant system and a bit more of a project than a single install.

    I guess the first issue I see is that, I don't see Polycom at all, any model in the drop down. I went to settings > Phone Provisioning updates and Polycom is not one of the listed manufacturers, all other manufacturers show up to date.

    Do I need to do something in order to have Polycom templates show up in the first place?

    Thanks.
     
  5. snowsam

    Joined:
    May 26, 2011
    Messages:
    79
    Likes Received:
    0
    It has been too long since v12 to remember for sure, but I'm 99% sure there were Polycom templates in there. They exist in 12.5 for sure. It sounds like yours are missing. Maybe someone deleted them? Can you install v12 on a test machine and see if you get the templates there and then move them over to your production machine?

    If they did exist, they were probably for Polycom's 3.3(?) series firmware, rather than the current versions that are for firmware v4 something.
     
  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,367
    Likes Received:
    83
    I am attaching the last phone templates that were released for V12.

    Download and extract all the contents into folder C:\ProgramData\3CX\Data\Http\Templates\phones\ . After doing this I can't remember, but you might have to restart the Web Server in order for them to show up in the Management Console but once that has been done you should see them in the extension settings.

    Because Polycom phones can be a bit fiddly to setup manually, I would recommend provisioning them with the Default Template using Option 66 as outlined by the guide you mentioned, http://www.3cx.com/sip-phones/polycom-soundstation-5000-6000-7000/ or using the provisioning link if the phones are already on firmware 4 or higher.
    Also worth noting that it is imperative that the phones be n the correct firmware.

    @snowsam:
    The guide is up to date in regards to the directory where the firmware should be placed. In regards to the languages, I think someone has already come in contact with you about this from the Support Department.
     

    Attached Files:

Thread Status:
Not open for further replies.