Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Polycom provisioning, adding options to template

Discussion in '3CX Phone System - General' started by FGCUHank, May 6, 2011.

Thread Status:
Not open for further replies.
  1. FGCUHank

    FGCUHank New Member

    Joined:
    Feb 27, 2010
    Messages:
    101
    Likes Received:
    0
    Hello,

    I have edited the default template and created my own specifically for the IP550. I have confirmed that my phone is calling the new template and not the original default polycom template.

    In my new template I have added/modified the following:

    in the <reg I have added reg.1.linekeys="2"
    this works and I have 2 of the 4 line keys displayed as expected

    in <up I have added up.welcomeSoundEnabled="1" and up.welcomeSoundOnWarmBootEnabled="1"
    in <saf I have added saf.1="SoundPointIPWelcome.wav"
    this works and on boot I now get the wav file played.


    in <bg I have
    bg.hiRes.color.selection="3,6"
    bg.hiRes.grey.selection="3,6"

    bg.hiRes.gray.bm.6.name="companylogo.jpg"
    bg.hiRes.color.bm.6.name="companylogo.jpg"

    And the desired logo file displays. I know I only need the gray for this phone but I put the color in there anyway so I don't forget when I go to configure the other phones and add new color Polycom phones

    Where I'm having trouble is in the and <dir options

    in <dir I have
    dir.local.volatile.4meg="1"

    But the phone is not downloading the 0000000000-directory.xml file each time it boots. I tested by changing an extension name after the boot and then rebooted the phone. I got this info from PJR's reply in the post titled Polycom phone book struggles

    Any input on the <dir option would be greatly appreciated.

    Thanks in advance.
    Hank
     
Thread Status:
Not open for further replies.