Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Polycom SIP650 language settings

Discussion in '3CX Phone System - General' started by D.C, Feb 3, 2015.

Thread Status:
Not open for further replies.
  1. D.C

    D.C

    Joined:
    Feb 3, 2015
    Messages:
    3
    Likes Received:
    0
    Hello,

    I successfully configured a polycom SIP650 on my 3CX 12 server, all is working well except the language setting :

    even if I set the LCD phone language to another one than English, the setting is not applied when the phone starts.

    I've to go through the phone menu "Menu -> Settings -> Basic -> Preferences -> Language" to select the desired language, and by this way it's works. But when the phone is restarted the language setting is lost, and the language reverts back to English.



    Please find my "mac-address-config" attached. (in txt extension)

    Any help would be appreciate.

    Thanks a lot :)

    David
     

    Attached Files:

  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,575
    Likes Received:
    305
    Does the Polycom allow you to export running config in a readable format that you can examine?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. D.C

    D.C

    Joined:
    Feb 3, 2015
    Messages:
    3
    Likes Received:
    0
    Hello Craigreilly,

    thanks a lot for your answer. You had a good idea !
    I saved the phone configuration before I changed language to another one than default English, and then just after I changed the language (through the phone menu).

    I compared both files and the following line is added after I changed the phone language :

    lcl.ml.lang="../firmware/polycom/SoundPointIPLocalization/French_France"


    I supposed I've to add this line to the MACADDRESS-config.cfg file, but don't know where and how.

    Please find both files attached.

    David
     

    Attached Files:

  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,575
    Likes Received:
    305
    If all phones need the same value - then I would put it into the template file.
    Polycom UC FW 4.x.x has this setting

    Code:
    <!-- Langauge Settings and Clock Format -->
    	<lcl>
    		<lcl.ml lcl.ml.lang="%%langwebUI%%">

    I have no experience with these phones so you'll have to play with this a bit...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. D.C

    D.C

    Joined:
    Feb 3, 2015
    Messages:
    3
    Likes Received:
    0
    Hello Craigreilly,

    I tried to insert the code you provided in the mac-confg file but without success, the phone reverts back to English after a restart.

    I tried to insert the following code : <lcl.ml lcl.ml.lang="../firmware/polycom/SoundPointIPLocalization/French_France"> but no success too.

    I've no idea why the phone doesn't apply this part of code correctly while all others settings (background line etc..) are applied successfully.
     
Thread Status:
Not open for further replies.