Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Polycom Soundstation Duo - No Incoming Calls connecting

Discussion in '3CX Phone System - General' started by MFreid, Feb 13, 2015.

Thread Status:
Not open for further replies.
  1. MFreid

    Joined:
    Oct 27, 2014
    Messages:
    16
    Likes Received:
    0
    Our company switched to 3CX from another phone system late last year. We've discovered that since that time, our Polycom Soundstation Duo conference room phones will not properly handle incoming calls.

    Other phones (3CX softphone, Yealink desk phones) work perfectly fine, this seems to be something specific to the Polycom phones. When an incoming call comes in, the call shows up, but pressing either the "answer" softkey or the "on hook" button do not answer the call; the ringing stops but a connection is not made.

    Hitting the decline softkey disconnects it on the Polycom side, and on the callers end, it goes to voicemail (after another 10-30 seconds)

    If a call comes in and nothing is done on the Polycom, and the caller disconnects (hangs up) it continues to ring on the Polycom until someone rejects the call (or answers, at which point it does the above)

    Outgoing calls are not affected.

    Any input would be appreciated.

    I've checked the settings on the Polycom against other phones. There is no difference between the settings of the Polycoms or the desk phones. I've checked the VOIP services settings between the old sub-account and the 3cx one. No difference. I've attempted multiple settings changed on 3CX (specifically under the "other" tab, compatibility checkboxes). Nothing doing.
     
  2. MFreid

    Joined:
    Oct 27, 2014
    Messages:
    16
    Likes Received:
    0
    Additionally, there are issues with calls not disconnecting with some phones and software. One example is that one of our users uses Ubuntu. Since there is no 3CX client for Linux, he uses another application (Zoiper). SWhen he answers a call and hangs up, the call doesn't drop. It stays on the phone queue that he is still servicing the call even though it's not active in Zoiper. This keeps him from answering other inbound calls.

    The inability of the soft phone to actually disconnect calls seems similar to the issue that we are having on the Polycom devices.
    There have been similar issues on older Linksys desk phones, but it does not occur in the 3CX softphone application or on Yealink devices. (T42, T46G)

    Any input would be appreciated.
     
  3. captain415

    Joined:
    Mar 4, 2012
    Messages:
    9
    Likes Received:
    0
    Sounds like a signaling issue. Have you try formatting your Polycom phone and re-provision it with the latest support firmware? Often times, if you change PBX and does not start your phones from scratch, some of the old setting may have left behind and cause problems.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,105
    Likes Received:
    329
    This sounds like a job for Wireshark. It would at least tell you what messages are being (or not being), sent, and where to lay the blame for it not working. It might also give you a clue as to what to "tweak".
     
Thread Status:
Not open for further replies.