Port Forwarding for presence on Android & Windows

Discussion in '3CX Phone System - General' started by verta, Aug 20, 2013.

Thread Status:
Not open for further replies.
  1. verta

    Joined:
    Aug 19, 2013
    Messages:
    11
    Likes Received:
    0
    Hi All,

    I've just installed 3CX PhoneSystem v12 for the company I work for. I'm having an issue with 3CXPhone for Android and 3CXPhone for Windows whilst out of the office.

    First off, my issue with Android.

    When our Android phones are out of the office, 3CXPhone for Android will connect to our 3CX PhoneSystem just fine for calls (via port 5060), however we get "Connecting..." stuck in the top left hand corner of the softphone, and we are unable to get any presence information or call history. Does this require additional port forwarding like the 3CX MyPhone did?

    Now, my issue with 3CXPhone for Windows.

    Whilst out of the office this will simply not connect, it comes up with the message that the 3CX PhoneSystem isn't available, however in the Accounts settings, the out of office IP & port are correct - I'm unable to click the icon to select office/out of office to change between modes though. Is this because it's in CTI mode? Is there a way to get it to switch to softphone mode whilst out of the office?

    FYI, the Firewall Checker passes just fine - ports 5060 TCP & UDP, 5090 TCP & UDP and 9000-90049 UDP are statically mapped.

    EDIT: I've ran Wireshark whilst opening 3CXPhone for Windows with the "Out of Office" selection in Accounts ticked and it's trying to connect on TCP Port 5000... this isn't mentioned anywhere in any tutorial, training video or the 3CX PhoneSystem v12 manual - is this correct?

    Any help is greatly appreciated.

    Kind Regards,

    Verta.
     
  2. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    Yes. MyPhone and other components use the web platform.. port forward 5000 TCP accordingly.

    As previously mentioned, presence/admin/provisioning runs on the web platform, thus 5000 TCP.

    It's a mixed bag whether or not to forward the port. Clearly if you want these features accessible from outside your LAN, you should. However, to get calls in and out of the system does not require that port be forwarded at all.
     
  3. verta

    Joined:
    Aug 19, 2013
    Messages:
    11
    Likes Received:
    0
    Thanks ian.watts, I'll set up port forwarding for TCP 5000 - we do indeed require presence out of the office, I'd have thought this would have been mentioned in the Manual under the 3CXPhone for Android (or iOS) section as it's surely going to catch others out given the amber icon on the main screen of the app!

    Cheers,

    Verta.
     
  4. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    380
    Likes Received:
    50
    Are you using the tunnel? If using the tunnel my understanding is that you just need port 5090 provided you manually provision the phones. If you aren't using the tunnel you should. Makes the connection much more reliable.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. verta

    Joined:
    Aug 19, 2013
    Messages:
    11
    Likes Received:
    0
    Hi lifeline,

    I've tried with and without the 3CX Tunnel enabled, both scenarios don't give any presence information on Android or Windows - we do get telephony though.
     
  6. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    Indeed, the web platform components (presence, management, provisioning, etc) do not tunnel.. only the calls.
     
  7. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,167
    Likes Received:
    75
    do not forget that https is on 5001 if configured!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    I'm having a weird issue, when using a tunnel connection

    1. I can make/hear incoming call
    2. I cannot make/speak in an outgoing call

    Caller ID does not work for remote....

    I have port forward the following, allowed all options for extensions from the 3CX System
    5090
    5060
    9000 9049
    5000

    Now the confusing part, the 3CX System at the Tunnel Tab, only gives the IP of the local machine
    But to have the tunneling work, I have to enter the Network Public IP at the 3CXPhone
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    I'm not certain what part is confusing. At the phone end, you have to put in the public IP of the 3CX server (PBX), or a URL. If you don't, how does the phone know where to register?

    You can receive an incoming call at the remote extension?

    Have you tried using the remote extension at multiple locations. If it is only at one location there may be an issue with the router there, or a conflict with other devices on the network. Moving it to another location would show whether it is the location, or a settings issue.
     
  10. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    Hello,

    Thank you for the reply

    I have tried it at many different locations, different networks,different extensions, different settings.

    Still same problem: Cannot make outgoing calls, people cannot hear you talking

    Even internally, within the same network, you can register a phone as outside office and to use the tunnel, and same result, no outgoing, once you switch to inside office, everything works just fine :D

    I have no clue what is going on
     
  11. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    178
    I recently used the tunnel at an office before our P2P network was installed.
    The phones PBX IP address was actually the internal address.
    And for the Proxy, you enter the IP Address of the Tunnel computer on the local network.

    http://www.3cx.com/blog/releases/sip-proxy-manager/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    Please see the photo attached of my config

    I have tried all options, same results, not being able to make outgoing calls, and if someone calls in, they cannot hear me speaking

    Once switching to my internal IP, all is going fine!

    I have forward the following ports, disable SIP ALG,
    5090
    5060
    9000 9049
    5000

    Does this have to do with something at the outbound rules settings?
     

    Attached Files:

    • 3cx.png
      3cx.png
      File size:
      49.9 KB
      Views:
      1,561
  13. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    178
    ahh - softphone, right.

    Is 10.0.0.4 where the tunnel software is running?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    Yes it is

    I have downloaded the SIP Proxy Mangment

    Same thing

    Maybe,it has to do with the Gateway setting? Cisco 3102
     
  15. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    Now the firewall check says port 9014 and 9032 are not opened

    Although I have done the forwarding for 9000-9049 UDP
     
  16. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    178
    Firewall on local machine?
    AntiVirus blocking ports on local machine?

    Can you give me a clearer layout of your network?
    Phone System local IP:
    Proxy Server IP: 10.0.0.4
    Remote Network IP Scheme:
    3cx Server/Office Network IP Scheme:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. tarmeeb

    Joined:
    Aug 28, 2013
    Messages:
    19
    Likes Received:
    0
    High,

    I have run the host PC (3CX System side) and client PC (3cxSoftPhone Side) both on VPN, same result

    My PC where 3CX System is installed : 10.0.0.4
    My Router Gateway is : 10.0.0.1
    My SPA 3102 is : 10.0.0.100
    My Router Public IP : Lets just assume 888.8.8.800

    Now Computer where soft phone is installed:
    PC where 3CX Softphone is installed : 127.0.0.150
    Router Gateway is : 127.0.0.1
    Public IP : Lets just assume222.2.2.200

    Not sure how this might help? My network structure?

    1. PBX Side (where 3CX Sys is installed)
    a) A router with public IP : 888.8.8.800 and local IP 10.0.0.1
    b) SPA 3102 IP: 10.0.0.100
    c) Computer where 3CX is installed and Tunnel 3CX IP is : 10.0.0.4

    Now I have tried remote extension on Androind and Windows Machines

    Same thing > incmoing calls are fine, you can hear voice, shows CID
    outgoing to even internal ext : Not happening
    hearing someone's voice : Not happening

    All options for Ext are checked-unchecked to allow it receive/send calls outside LAN

    I have tried using SIP proxy manager by 3CX, same result.

    Actually I have a question for you, do you have a copy of a backup files for a 3CX config files working fine?Maybe I am missing something with the config?!!! Or it has to do with the SPA3102 config itself?
     
Thread Status:
Not open for further replies.