Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Presenting DDI as CLI

Discussion in '3CX Phone System - General' started by JamesSquire, Aug 13, 2010.

Thread Status:
Not open for further replies.
  1. JamesSquire

    Joined:
    Aug 13, 2010
    Messages:
    7
    Likes Received:
    0
    I have just switched from an Epygi Quadro PBX to a 3CX free PBX. I have managed to replicate all my configuration, except for one thing.

    I cannot work out how to present a user's DDI as their outgoing CLI.

    Can anyone suggest how I do this?

    Thanks.
     
  2. nwhitfield

    Joined:
    May 15, 2010
    Messages:
    35
    Likes Received:
    0
    It depends on the provider, I would guess. I just ported my ISDN lines onto a Gamma SIP trunk. They require the caller ID you send outbound to be the national number, less the leading zero, so for the number 020 8880 xxxx on my office extension, edit the extension, click the Other tab and enter 208880xxxx in the Outbound Caller ID box.

    In the Outbound parameters section of the VoIP provider, I had to make sure that the From field was corrrectly configured; I have mine set to "From: User Part" = "OutboundCallerID from Extension settings" and "From: Host Part" is set to "ContactUri"

    Depending on what your provider wants, you may need to tweak differently.

    Also, note that there's an 'Outbound caller ID' on the port screen for the provider; I left that blank.

    I also had to prod the provider to authorise the caller IDs in their database, which they didn't do by default. But if it's been working with your old kit, that shouldn't be an issue.
     
  3. JamesSquire

    Joined:
    Aug 13, 2010
    Messages:
    7
    Likes Received:
    0
    Thanks a lot for your suggestions. The Outbound Parameters configuration worked! :)
     
  4. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    We also use Gamma - out of interest, do you use IP authenticated or username/password authenticated accounts?

    And Gamma *always* forget to add the DDI's to their allowed caller ID lists when we provision accounts too! :lol:

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. nwhitfield

    Joined:
    May 15, 2010
    Messages:
    35
    Likes Received:
    0
    IP authenticated; I had to tinker with the settings to get the numbers to present ok, but other than that all seems fine.

    Next thing to work out is what to do about fax.
     
  6. extrascope

    Joined:
    Jan 31, 2010
    Messages:
    4
    Likes Received:
    0
    Hi, could you offer some assistance with this. I also use gamma and am stuck with the Forbidden response to all my outgoing calls. I think its because 3CX is sending number not IP as you describe. Can you offer any assistance in how to set this up? Thanks
     
  7. ccomley

    Joined:
    Apr 6, 2011
    Messages:
    95
    Likes Received:
    4
    Can I add a few notes to this thread?

    First on CLI, you may need to make sure 3CX is setting the PAID (P-Asserted Identity) variable on the SIP Invite as well as the FROM and RPID variables to ensure the CLI you WANT to display is correctly passed. This is because the standards appear vague and some operators pick up one, some pick up the other.

    In the "Outbound Parameters" box add the Sip Fields...

    - P-Asserted Identity: Display Name - Set it to "Caller Display Name"
    - P-Asserted Identity: User Part - Set it to "Outbound Caller ID"
    - P-Asserted Identity: Host part - Set it to "GWHostPart"

    For the person saying they're getting "Forbidden" - I fear you've hit the snag with Gamma sip trunks only working properly if the 3CX box has a public IP address on its WAN NIC, not a NAT mapped address.
     
Thread Status:
Not open for further replies.