Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Private IP in INVITE header

Discussion in '3CX Phone System - General' started by eug, Apr 7, 2010.

Thread Status:
Not open for further replies.
  1. eug

    eug

    Joined:
    Mar 2, 2010
    Messages:
    36
    Likes Received:
    0
    My SIP trunk provider (MyNetFone) does authentication based on the public IP and DID in the INVITE header. I'm having problems making outgoing calls - the SPA525G phone says Connecting, and eventually Temporarily not available.

    I enabled verbose logging and noticed that the INVITE header has my internal IP address - is that a function of the phone, 3CX, or my router?

    I rang up MyNetFone and the tech I spoke to did a trace while i made a call, and said yeah, the problem is my internal IP address in my INVITE header - it needs to be my public IP address. How do I change that?

    The router I intend to use is a pfSense box, I also did testing with a Linksys RVS042 and it did the same thing.

    here is the log, stripped of phone numbers:

    Code:
    17:10:19.539  [CM503020]: Normal call termination. Reason: No answer
    17:10:19.539  [CM503016]: Call(3): Attempt to reach "0408xxxxxx"<sip:0408xxxxxx@192.168.2.1> failed. Reason: No Answer
    17:10:19.539  [CM503003]: Call(3): Call to sip:0408xxxxxx@sip20.mynetfone.com.au:5060 has failed; Cause: 408 Request Timeout; internal
    17:10:06.427  Active calls counted toward license limit: [3]
    17:09:47.402  [CM503025]: Call(3): Calling VoIPline:0408xxxxxx@(Ln.10008@MyNetFone Trunk)@[Dev:sip:0731xxxxxx@sip20.mynetfone.com.au:5060]
    17:09:47.402  [MS210002] C:3.2:Offer provided. Connection(transcoding mode): 192.168.2.1:7008(7009)
    17:09:47.012  [CM503004]: Call(3): Route 1: VoIPline:0408xxxxxx@(Ln.10008@MyNetFone Trunk)@[Dev:sip:0731xxxxxx@sip20.mynetfone.com.au:5060]
    17:09:47.012  [CM503010]: Making route(s) to "0408xxxxxx"<sip:0408xxxxxx@192.168.2.1>
    17:09:47.012  [MS210000] C:3.1:Offer received. RTP connection: 192.168.2.151:16436(16437)
    17:09:47.012  Remote SDP is set for legC:3.1
    17:09:47.012  [CM505001]: Ext.100: Device info: Device Identified: [Man: Cisco;Mod: SPA Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [Cisco/SPA525G-7.4.3] PBX contact: [sip:100@192.168.2.1:5060]
    17:09:46.997  [CM503001]: Call(3): Incoming call from Ext.100 to "0408xxxxxx"<sip:0408xxxxxx@192.168.2.1>
    17:09:46.997  [CM500002]: Info on incoming INVITE:
      INVITE sip:0408xxxxxx@192.168.2.1:5060 SIP/2.0
      Via: SIP/2.0/UDP 192.168.2.151:5060;branch=z9hG4bK-fd6e410f
      Max-Forwards: 70
      Contact: "Reception"<sip:100@192.168.2.151:5060>
      To: "0408xxxxxx"<sip:0408xxxxxx@192.168.2.1>
      From: "Reception"<sip:100@192.168.2.1>;tag=910e7036de7c5b5bo0
      Call-ID: ef119992-ad55e1af@192.168.2.151
      CSeq: 102 INVITE
      Expires: 240
      Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER, UPDATE
      Proxy-Authorization: Digest username="100",realm="3CXPhoneSystem",nonce="414d535c01ccc0ba13:c3dd986539e1d597dcd713b23856689d",uri="sip:0408xxxxxx@192.168.2.1:5060",algorithm=MD5,response="6a4ca5239cf3701a0d802e1fc52e704b"
      Supported: replaces
      User-Agent: Cisco/SPA525G-7.4.3
      Content-Length: 0
    

    edit: I ran firewall checker and it failed on Phase 2a:
    <18:11:26>: UDP SIP Port is set to 5060. NO RESPONSE received. Phase 2a check FAILED.
    Application exit code is -2

    I did the unthinkable and created a PPPoE connection from windows direct to the bridged modem without a firewall running, and it still gave the same error.
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    This requires in depth troubleshooting. Please open a ticket via the support portal and send us the support logs and a wireshark capture of the reproduced call.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.