Probleb wich Sipgate

Discussion in '3CX Phone System - General' started by alma, May 29, 2007.

  1. alma

    Joined:
    May 28, 2007
    Messages:
    1
    Likes Received:
    0
    Itry to setup SIPGATE wiech 3CX, but allways recive error when try to dial VOIP LINE

    09:45:41.125 CallConf::Rejected Call(C:8) is rejected: Loop Detected (no match)
    09:45:41.125 StratInOut::eek:nCancel Call(C:8): Call from Ext.111 to terminated; reason: Loop Detected (no match)
    09:45:40.984 MediaServerReporting::STUN from 'homenet615:0/MediaServer':possible firewall problem. Address mapping failed on STUN server 217.10.79.2:10000 for local address ":9002"
    09:45:40.796 CallConf::eek:nIncoming Call(C:8): Incoming call from Ext.111 to sip:9@10.23.5.193
    09:45:15.250 ClientRegs::eek:nSuccess Registration of sip:5003980@sipgate.co.uk is successful
    09:45:15.000 ExtLine::Register Send registration for "004918019955003980"<sip:5003980@sipgate.co.uk>
     
  2. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    Sipgate

    Outbound Proxy Hostname or IP : BLANK
    Outbound Proxy Port (default is 5060) : BLANK

    Have you opened your firewall/router for UDP 8000-8030 (Mmmm)
    and set 3CX voip Provider ports 8000-8030 (Average, but some would say more!)

    Lastly the STUN setting?

    Im trying to remember what I had the most problems with when setting up a provider.
     
  3. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Re: Sipgate

    Hi

    Are you sure you mean ports 8000-8030, I thought the default ports were 9000-9499 ?

    Kev

     
  4. etm_ltd

    Joined:
    Nov 18, 2006
    Messages:
    69
    Likes Received:
    0
    CreativeHubLtd

    Usually ports 8000-8xxx are used for VoIP, but as 3CX you can use 9000-9xxx.

    The only thing you have to do, is to think opening rights ports through you firewall.
     
  5. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Hi

    Thanks for that, I am using the default ports for external calls, and I have them forwarded on my firewall to my 3CX server, however I am able to make outgoing calls but not recieve incoming calls.

    On my firewall I have the following ports forwarding to my 3CX Server :

    5060 - SIP
    3478 - STUN
    9000-9007 - RTP
    10000 - Sipgate STUN Server

    On the Sipgate website it shows me as being online, and in the 3CX server logs it shows my registration into my sipgate account, but if I dial my 0845 number from my mobile or another landline I get the default sipgate message that I am offline and I get no entry in the server logs, do you have any idea's ?

    Kev
     
  6. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    Settings

    Have to ticked, under registration settings:

    [] Both in/out calls

    And under general settings, ports to use for external calls:

    8000 to 80xx etc ..

    or 9000 to 90xx in your case?

    How are you getting on with this one? I have sipgate working here so it will do it, Graeme.
     
  7. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Hi Graeme

    Thanks for your reply, sorry I haven't replied sooner, I am holiday at the moment.

    I have Both In/Out Calls ticked, and Ports for External Calls 9000 - 90xx open.

    I had some problems with the hardware phone I was using, a Safecom SDP5000, but following a full reset and reprogramming of the phone I can now get incoming calls routed to it OK.

    I have issues now with the quality of calls between internal extensions which is very poor and "wobbly", however when making or receiving external calls, the sound quality is good.

    Kevin
     
  8. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Hi Graeme

    An update for you, I have had the server turned off for 3 days whilst I have relocated it in the rack, and now I can't get my Sipgate line registered, I keep getting "Line DN='10000' device='Sipgate' can not be registered. External IP isn't resolved."

    I have tried using different STUN servers but still not joy.

    I am currently using the 3CX stun servers and the Sipgate stuns servers

    Kev
     
  9. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Hi

    The only way I could get the Sipgate line registered was to change the setting in Line Management - Manage Gateways and Providers - Sipgate - Registration Settings - Which IP to use in 'Contact' field for registration: from External (STUN Resolved) to Both (external and internal) and the line now works fine !

    Kev
     
  10. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    setup...

    If you download the support app at http://aacnet.eu/3cx
    and call me we can set up a support session.
    Dont do the steps below untill we are talking or typing...

    1) Open TCP port 5481 through your firewall (temp only!)

    2) select SETUP-->3CX LOG-->OPEN LOGIN

    after we have finished, CLOSE the 5481 passage through your firewall for security, and select SETUP-->3CX LOG-->CLOSE LOGIN
     
  11. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    Solved..

    Ok Kev, thats solved that then.

    I was planning on looking at all the STUN settings yo had, inc. the one under GENERAL setup.

    But, if it works, leave it I say!!

    Graeme.
     
  12. CreativeHubLtd

    Joined:
    Aug 15, 2007
    Messages:
    37
    Likes Received:
    0
    Hi Graeme

    Thanks for all your help and offer of remote assistance, I am not sure why it only works like that now, it was working fine before, but as you say if it works then don't change it ! Very frustrating as to why things keep changing and then you have to start adjusting settings to get things back on track

    Kev
     

Share This Page