Problem in template for Linksys SPA3102

Discussion in '3CX Phone System - General' started by ejvind1212, Aug 14, 2008.

Thread Status:
Not open for further replies.
  1. ejvind1212

    Joined:
    Jul 7, 2008
    Messages:
    8
    Likes Received:
    0
    Hi

    If you install a clean version of 3CX 6.0.806 and configure Linksys 3102 according to 3CX guide, it works OK.

    However, if you enable "PSTN CID For VOIP CID" under the PSTN tab to show caller id on Linksys SPA3102, you will se an authorization failure for SIP Invite in the 3CX log file. This is case with firmware version 3.3.6, 5.1.5a and 5.1.7 of the Linksys 3102.

    I think that this worked OK until the newest version of 3CX. However, I can not verify this as I do not have the install file for the previous version anymore, and on the 3CX web site only the newest version is available.

    Maybe it can be solved by changing some of SIP parameters in 3CX, but I do not know what should be changed.

    Thanks.

    Ejvind
     
  2. Henk

    Henk Member

    Joined:
    Nov 13, 2007
    Messages:
    250
    Likes Received:
    0
    What are your settings for the SPA gateway in 3CX?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ejvind1212

    Joined:
    Jul 7, 2008
    Messages:
    8
    Likes Received:
    0
    I have tried to attach a screen shot of my settings. It should be standard settings for Linksys SPA3102 as far as I know.



    Thanks.

    Ejvind
     
  4. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    Hello,
    change gateway port to 5061
     
  5. ejvind1212

    Joined:
    Jul 7, 2008
    Messages:
    8
    Likes Received:
    0
    The Linksys SPA3102 is configured according to the 3CX guide, and in this guide port 5060 is used in the PSTN tab. Hence, if I change the port to 5061 in 3CX, it will no longer work.
     
  6. galal202

    galal202 New Member

    Joined:
    Jun 23, 2008
    Messages:
    235
    Likes Received:
    0
    Hello Ejvind1212,
    line one port 5060
    pstn port 5061
    at 3cx and spa
    I'm sure
     
  7. ejvind1212

    Joined:
    Jul 7, 2008
    Messages:
    8
    Likes Received:
    0
    The 3CX guide is available on this link: http ://www.3cx.com/voip-gateways/linksys-3102/ - NO LONGER AVAILABLE. If you scroll down you will see that under the PSTN tab, the SIP Port is 5060. I am aware that the factory setting on Linksys SPA3102 is 5061 on the PSTN tab and 5060 on Line 1 tab.

    So now I have port 5060 on both 3CX and Linksys SPA3102, and ordinary telephoni without caller id is OK. Why should changing both ports to 5061 make the caller id feature work correctly?
     
  8. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    Do as Galal202 said
    and set "PSTN Answer Delay:" to 5
     
Thread Status:
Not open for further replies.