Problem installing 3CX Phone on xperia X10i

Discussion in 'Android' started by Pablooo, Oct 18, 2011.

Thread Status:
Not open for further replies.
  1. Pablooo

    Joined:
    Oct 5, 2011
    Messages:
    16
    Likes Received:
    0
    Hi,

    I tried to install 3CXPhone on my Xperia, the phone was recognized in 3CX Console as "NEW" and I tried to Assign extension (new one or existing extension) but this never works even with the "Provision 3CXPhone with Tunnel enabled for remote connections" switching to enable.
    Then I made a big mistake REJECTING my xperia phone in "phones" section. Now I don´t know how to configure my phone again. I uninstall 3CX from Xperia and install it again, I reboot 3CX Console, I delete and try with another account from my Xperia phone but none of these works to get phone recognition again.

    How can I get my xperia recognized if I mistakenly Reject this phone?
    once I get this...
    How can I assign an extension that works with my xperia?

    I have Android 2.3.3

    Thanks for your help!
    Pabloo
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,498
    Likes Received:
    67
    Hi Pabloo
    There might be three possible reasons:

    - 3CX PBX is configured to a different SIP port than standard 5060.
    For autoprovisioning, 3CXPhone performs a broadcast request to port 5060, so if there is no 3CX PBX to listen on this port, nothing will happen. FIX: configure PBX to port 5060.
    *** In this case, your 3CXPhone will NOT appear listed bold in PBX's Phones stats.

    - your Android phone is not connected to the same local network as 3CX PBX
    The broadcast request is valid on a local network. Therefore, if you're using 3G, for sure autoprovisioning will not work. Also, if your Android is part of, let's say, 10.x.x.x network and PBX on 192.x.x.x, autoprovisioning will not work. FIX: configure Android to use the same local network as PBX.
    *** In this case, your 3CXPhone will NOT appear listed bold in PBX's Phones stats.

    - you're trying to assign 3CXPhone to an outdated existing extension.
    This is an issue in the PBX management console: the PBX local IP has been changed sometime after an existing extension has been created. Extension's provisioning file "cached" the old IP, which now is, obviously, no longer available. FIX: create a new extension or assign to one created with current PBX IP.
    *** In this case, your 3CXPhone WILL appear listed bold in PBX's Phones stats, but once assigned, 3CXPhone will display a blank account.

    Hope it helps.
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Pablooo

    Joined:
    Oct 5, 2011
    Messages:
    16
    Likes Received:
    0
    Hi Vali,

    My 3CXPhone used to Appears listed bold in PBX's Phones stats, SIP port 5060 was ok and android phone was on the same local network.

    About assigning an outdated extension, I tried with an existing extension and also creating a new extension. Even the blank account you mention was not the problem, I create an account named "adrian" in my xperia and was showed in green and with account name in left side but without telephone above..
    http://www.3cx.com/blog/3cxphone/android/configuring/
    finally when I pass to 3CXPhone dial section the status on the phone was "not connected".

    Seems to be a problem in 3CX console, the Android Phone was listed bold in PBX's Phones stats but I never can assigned to an extension that works with it. Now I have a bigger problem, I just mistakenly REJECT Android Phone from PBX's Phones stats and I cannot bring it back even If I made a new account on my xperia. I saw that if I delete and install again 3CXPhone in Xperia, this brings last account configuration for default but in my PBX's Phones stats don´t appears again, this might be because of the MAC on my xperia? the one that was deleted from PBX's Phones stats once before?

    Was not difficult to use and understand 3CX PBX till here but this issue is getting me crazy...
    thanks for your help,
    Best regards,

    Pabloo
     
  4. antler

    Joined:
    May 8, 2011
    Messages:
    40
    Likes Received:
    0
    Hi Vali,

    Unsure if I should raise this question in a different forum but here goes?

    I downloaded the recent version msi6 of the 3cx softphone. As there are no accounts configured, I receive the expected response to select either 'Auto Provision' or 'Create Profile'.
    Selecting 'Auto Provision', I would expect to observe 'new' I believe on the phone tab of the 3cx management console, but I do not.
    Due to hardware restrictions, I have to use a non-default sip port, i.e. I can not use 5060 BUT should I still observe the 'new' option under the 'phones' tab?

    Is there another reason as to why I am do not see a 'new' app?

    Appreciate any help,

    Antler.


    Just realized I have logged this in the 'Android' area so please ignore, I will raise in the correct area, duh!!! Antler
     
Thread Status:
Not open for further replies.