Problem W/ Installer?

Discussion in '3CX Phone System - General' started by refiking, Feb 10, 2010.

Thread Status:
Not open for further replies.
  1. refiking

    Joined:
    Jul 2, 2008
    Messages:
    12
    Likes Received:
    0
    Hey Guys,

    I used 3cx over a year or so ago and it worked great. I had another project that just came up that needs what 3cx can offer. Went to grab the new installer and no dice. I've tried it on 2000, XP, and 2003. They all give me the same error:

    There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.

    Anyone have a less recent version maybe? Any and all help, as always, is truly appreciated!
     
  2. refiking

    Joined:
    Jul 2, 2008
    Messages:
    12
    Likes Received:
    0
    I found the problem. The installer said I needed 2.0 framework but I really needed 3.5

    Might want to update that in the installer package...
     
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,123
    Likes Received:
    150
    Before you install 3CX make sure that your machine is FULLY up to date with the latest updates.

    This is a generic error that can come up for many reasons. Not 3CX related. If you google this, you will see that in many other application forums this error came up.

    In your case your error is MSI / windows installer related. Not because you did not have .net 3.5.

    Full windows updates will fix this installer issue.
    thanks for your feedback.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. eug

    eug

    Joined:
    Mar 2, 2010
    Messages:
    36
    Likes Received:
    0
    I had the same intaller package script required could not be run error message on a fresh w2k3 server with nearly all updates installed.

    I installed *only* the .net framework 3.5 SP1 update specifically (KB951847) and rebooted, and 3cx installed without a hitch after that.
     
  5. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,473
    Likes Received:
    94
    You could always try installing Windows Script 5.7 or any newer version out there.
    I heard some people fixing similar problems by doing that.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jeremymcnelson

    Joined:
    Mar 19, 2010
    Messages:
    2
    Likes Received:
    0
    Sometimes the problem itself is compatibility. Try to check your manuals for compatibility issues. And let me emphasize that again, SOMETIMES.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.