Problem when attempting to transfer to Digital Receptionist

Discussion in '3CX Phone System - General' started by Ralph, Aug 10, 2007.

  1. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    I have an extention set up to transfer to a digital receptionist if there is no answer.

    This works fine so long as the "No Answer After" setting does not exceed 15 seconds. If this setting exceeds 15 seconds (say 30 seconds) then the phone plays a recording like it is going into a voice mail box instead of transferring to the digital receptionist (even though the extension itself does not have voice mail enabled). It doesnt record a message either.

    Anyone know what is going on or how I can increase the No Answer After setting so I can have the phone ring longer before transferring to the digital receptionist??

    The device that uses the extension is a Grandstream Handytone 496 ATA and the 3CX server is on a Windows Server 2003 machine with a P4 3Ghz CPU and 1 gig of Ram. There are no error messages or unusual entries in the logs.

    Any ideas?

    Thanks again
     
  2. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    DR divert

    Could your sip device time out and sent a sig back? Im not too sure on the one your using.

    My other thought - if this were to happen have you tried filling in the divert if BUSY and NO ANSWER and NOT REG fields, and see if anything different happens. I know the voicemail is turned off, but could there be some kind of glitch.

    Ill try to set up an extension the same way and have a poke around.

    Graeme.
     
  3. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Hi

    Good afternoon GBarnes,

    The "BUSY", "NO ANSWER and "NOT REG" fields are all set to transfer to the digital receptionist.

    I have tried resetting all of them to transfer elsewhere but nothing seems to fix the 15 second limitation.

    Thanks again,
     
  4. gbarnes

    Joined:
    Aug 3, 2007
    Messages:
    83
    Likes Received:
    0
    Tried it!

    Hello again...

    I tried it on mine and it worked. Im sure it might be something to do with the sip device then, how about testing with a softphone? On the same extension.

    At least that may narrow it down?

    Im baffled. :(
     
  5. Anonymous

    Anonymous Guest

    Ralph,

    Can you post some Server logs of that call?

    Being the 30 sec mark that is (like mentioned) close to the SIP registration. In particular the Re-Invite, try to increase or decrease the re-invite on your ATA.

    But post the logs so we can see what it does, well we try atleast. (still trying to figure those darn things out myself :))
     
  6. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    You gotta believe this.

    I had an epiphany last night.

    It turns out the phone attached to the Grandstream ATA has a built in voice messaging system (The ghost message box I couldn't explain) that was set at 4 rings. :shock:

    So when ever I set the timer on the 3CX server beyond the time needed for 4 rings, the voice message system built into the phone would pick up.
    Once I disabled the voice message system built into the phone everything worked fine.

    It always seems that the most perplexing problems have an obvious answer that is somehow overlooked in favor of more complex explanations. :roll: . I'll try not to make the same mistake again. :lol:

    Thanks again for all the help.
     

Share This Page