Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Problem when using domain name instead of IP

Discussion in '3CX Phone System - General' started by broesder, Dec 5, 2008.

Thread Status:
Not open for further replies.
  1. broesder

    Joined:
    Jul 21, 2008
    Messages:
    9
    Likes Received:
    0
    Hi,

    I asked my service provider to connect one of my domain names to the IP address of my hosted 3cx. When I connect my phone (GXP-2020) by this domain name the phone does register, but when I want to make a call, the phone gives a busy tone with failure code "403 FORBIDDEN".

    Does anyone know what my problem can be??

    Thanks!!

    The log from my server:

    15:23:34.920 Call::Terminate [CM503008]: Call(673): Call is terminated
    15:23:34.920 CallCtrl::eek:nIncomingCall [CM502001]: Source info: From: 673; To: "Kantoor"[sip:105@broesder.eu;user=phone];tag=6ffac5cb7dfa314b[sip:999@broesder.eu;user=phone]
    15:23:34.920 CallCtrl::eek:nIncomingCall [CM503013]: Call(673): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 999@broesder.eu tid=295a6d6a627deccf cseq=INVITE contact=105@92.66.80.82:24070 / 38830 from(wire)
    15:23:34.748 evt::CheckIfAuthIsRequired::not_handled [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:999@broesder.eu;user=phone SIP/2.0
    Via: SIP/2.0/UDP 92.66.80.82:24070;branch=z9hG4bKb88cfba85552257e
    Max-Forwards: 70
    Contact: [sip:105@92.66.80.82:24070;transport=udp;user=phone]
    To: [sip:999@broesder.eu;user=phone]
    From: "Kantoor"[sip:105@broesder.eu;user=phone];tag=6ffac5cb7dfa314b
    Call-ID: 6886facb19d1f502@192.168.0.103
    CSeq: 38829 INVITE
    Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, INFO, SUBSCRIBE, UPDATE, PRACK, MESSAGE
    Supported: replaces, timer, path
    User-Agent: Grandstream GXP2020 1.1.6.44
    Content-Length: 0


    15:23:34.748 evt::CheckIfAuthIsRequired::not_handled [CM302001]: Authorization system can not identify source of: SipReq: INVITE 999@broesder.eu tid=b88cfba85552257e cseq=INVITE contact=105@92.66.80.82:24070 / 38829 from(wire)
     
  2. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    Your problem is probably due to the fact your phone is inside the same network with the 3CX server, and so when the phone looks up the DNS name it gets the external address of the firewall, and hence the phone tries to connect to that, and most firewall providers don't allow a route between the inside to the outside IP address of the router and then back in via the NAT ports.

    The solution for you is to use "split DNS" which is basically running a DNS server internally as well (e.g. a SBS server or likewise) into which you replicate all the internal services which are referenced from the internet, but reference them by their LAN IP address. If you then run the LAN DNS server with forwarding, it should mean that any address looked-up either from the inside or the outside of your network should give you the relevant IP address (of the server or the firewall respectively), and hence work seamlessly.

    Hope that helps.
    Mike.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. broesder

    Joined:
    Jul 21, 2008
    Messages:
    9
    Likes Received:
    0
    Thanks for the fast reply!

    But no, the 3cx is not in the same network, it is a hosted server somewhere in the country.

    Johan.
     
  4. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    DNS is purely a name-to-IP-address mapping, and all lookups are done as-needed (although the device may contain a small DNS cache).

    Do your handsets work when referenced purely on an IP address basis then?

    (as this might explain an issue i've been having with remote handsets too)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. broesder

    Joined:
    Jul 21, 2008
    Messages:
    9
    Likes Received:
    0
    Hi,

    With the IP address in the SIP server and Proxy server field everything works fine. As soon as I change those into my domain name, the phone registers, the BLF lamps are working, but I can't make calls.

    Regards, Johan.
     
  6. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    One thing to test is the DNS server configured into your phone? as your phone will not be able to resolve the address without one.

    Cheers,
    Mike.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. arvine

    Joined:
    Jun 26, 2009
    Messages:
    10
    Likes Received:
    0
    Hi, im having the same problem here, when we use IP address instead of DNS name when identifying the SIP server for 3cx, everything is ok. Buti when we use DNS name instead of IP add, we cant make calls. Please take note that we are using a split-dns infrastructure. Meaning whether 3cx is access outside or inside, it is resolved properly. I’m sure dns is properly resolved to the correct ip – but why it doesn't work ?

    The issue is internal testing does not allow calls, registrations succeeds on some device but fails on the 3cx voip client.. Please help me.. Thanks
     
  8. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    Arvine, it appears to be a 3CX "peculiarity". You'd think they'd use the normal GetHostByName function, but apparently not.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. arvine

    Joined:
    Jun 26, 2009
    Messages:
    10
    Likes Received:
    0
  10. thenua

    Joined:
    Jun 5, 2009
    Messages:
    38
    Likes Received:
    0
    Hi broesder, Hi arvine,

    I faced similar issues. Not sure what the "correct" way is, but the following worked for me.

    On 3CX, goto Setting > Advanced > Settings for Direct SIP calls and add your domain name to field "Local SIP Domain". Hopefully the domain used externally is the same used internally on the LAN on which the 3cx is running. If so, that should work. (I have this working on a recent version 7 instalation).

    If an internal domain name exists and is in use on LAN which is different from the external domain name in use on Internet, then it gets trickier. I have this working on a Version 6 instalation of 3cx. Here is what I did. (On version 6, the menu structure is very slightly different but same result) ...
    (1) Goto General Settings > Settings for direct SIP calls
    (2) put the external domain name in the "local sip domain" field
    (3) turn on "Allow calls to local SIP uris"

    Now the tricky part. I use SPA942 handsets. So the terminology maybe slightly SPA specific here. Not sure how it translates to the Grandstream world :
    (1) (SIP) Proxy is set to the external domain name
    (2) Outbound Proxy is set to the internal domain name
    (3) and finally "Use outbound Proxy" is set to YES.

    When all this is done, the handset works fine for me using the DNS names instead of the IP address.

    There is a little written here that maybe useful :
    http://www.3cx.com/support/sip-domain.html

    Regards,
    Andrew (thenua)
     
  11. arvine

    Joined:
    Jun 26, 2009
    Messages:
    10
    Likes Received:
    0
    thanks.. that solved our internal testing problem..
     
  12. Angus

    Joined:
    May 12, 2009
    Messages:
    3
    Likes Received:
    0
    Well I am new in VOIP world, so I am trying to learn how to use this system. Through this forum I am learning a lot.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.