Problem with 3CX and Peoplefone. Cannot etablish communication with SIP trunk (5060)

Discussion in '3CX Phone System - General' started by IT_VBO, Oct 6, 2017.

Thread Status:
Not open for further replies.
  1. IT_VBO

    Joined:
    Sep 22, 2017
    Messages:
    22
    Likes Received:
    0
    Hello,

    I tried many configuration's changes. I never can etablish/register to the SIP trunk provider.

    06/10/2017 12:15:07 - Registration attempt for Lc:10000(@peoplefone[<sip:90760634385@sip.peoplefone.ch:5060>]) is scheduled in 40 sec.


    Testing 3CX SIP Server... failed (How to resolve?)
    • stopping service... done
    • detecting SIP ALG... failed (How to resolve?)
    • testing port 5060... full cone test failed (How to resolve?)
    • starting service... done
    We have a Forigate Firewall and i followed the recommendation's from 3CX. Change nothing.

    Peoplefone SIP provider saying having a problem on 3CX side or Firewall Side.

    I opened a support ticket at Fortinet.

    But i would check the configuration of 3CX too.
     
  2. dab

    dab

    Joined:
    Nov 1, 2009
    Messages:
    67
    Likes Received:
    1
    3CX is running fine with a peoplephone.ch trunk and Fortigate v5.4.x
    There must be a configuration problem on the Fortigate, on 3cx you can't do anything wrong with the provided trunk config.
    To get the Firewall Test green you have to do things on the Fortigate you won't like for security reason. But you can get a fully running and secure config.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. OCWI

    OCWI New Member

    Joined:
    Jan 17, 2017
    Messages:
    161
    Likes Received:
    46
    Any sip ALG on the ISP side? Those Fortigates can be very odd, make sure there isnt any sort of "dynamic" ports or anything like that going on.

    The other idea would be to backup the PBX, spin up a hosted PBX (use OVH or google, or AWS - tons of guides on here) and restore from backup.

    Then throw in a raspberry pi border controller provision the phones to that. That should successfully traverse your firewall issues and eliminate your issues.
     
  4. IT_VBO

    Joined:
    Sep 22, 2017
    Messages:
    22
    Likes Received:
    0
    Finally i was able to do the SIP connection, but now, i can ear the caller (or if i call it), but the caller cannot ear me.

    Is like having only one way, not both way.
     
  5. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,216
    Likes Received:
    88
    this still indicates that the firewall re-writes or blocks traffic in the exchange with the provider. Very Important is in the Fortigate guide the bottom part and to delete/disable those rules!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. IT_VBO

    Joined:
    Sep 22, 2017
    Messages:
    22
    Likes Received:
    0
    But at the port 5040 ? 9000-9255 ?

    Apparently internal call made same. I suspect an local anti-virus blocking call's.
     
Thread Status:
Not open for further replies.