Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Problem with incomming call via VOIP provider

Discussion in '3CX Phone System - General' started by adza, Feb 20, 2008.

Thread Status:
Not open for further replies.
  1. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Hi,

    I have our system setup to use a number of VOIP providers. Amongst which - i have setup an option for incomming VOIP calls to be directed / routed to the 3CX server.

    I'm finding a problem in that I can have this setup, and it works fine - but then after a few minutes, it will not receive any calls. Anyone trying to call through just gets silence on there phone.

    According to both 3CX, and the end VOIP provider, I am still registered, but the calls won't come through. If I restart the 3CX server, the calls will come back through again for a period of time.

    I am behind a NAT firewall to have access to the internet. I have opened up port 5060 from the outside to go to my 3CX server. There are no restrictions on outbound packets.

    Can anyone suggest what might be causing this?

    Thanks & Regards

    Adam.
     
  2. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Aah - I think I may be onto something...

    When 3CX registers with my VOIP provider, apparently it gives the provider a 'rinstance' ID.

    ie... sip:xxxxx@xxx.xxx.xxx.xxx:5060;rinstance=a139c126a2692449

    I'm thinking that when 3CX re-registers, it changes this ID, but my VOIP providers ID doesn't seem to change unless I initiate something within 3CX. I'm therefore guessing that when the call is passed through to 3CX, it's passing the wrong "rinstance" id, and therefore the call is 'dropped'.

    I'm now guessing (providing my guess above is accurate), I want to make a change somewhere in the "Source Identification" to match my "line number" instead of the rinstance id.

    Is anyone able to confirm whether or not this is what I should be looking at, or whether I'm way off?

    Thanks & Regards

    Adam.
     
  3. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Interestingly enough - no log entries appear (even in verbose mode) when I try calling myself when this error occurs.

    When I first start the server, everything works fine, but if I wait about 5 mins, no incomming calls will get through to me.

    Is there a way to open up 3CX so it will receive calls on a particular port regardless of what tags are included in the call?

    Thanks & Regards

    Adam
     
  4. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    I'm not sure if this helps - but this is the information in the log that comes through IF the call gets in. (Normally only within the first few minutes of registration with the provider)

    21:13:28.312 Call::Terminate [CM503008]: Call(11): Call is terminated
    21:13:28.296 LineCfg::getInboundTarget [CM503011]: Inbound office hours' rule for LN:10003 forwards to DN:800
    21:13:08.375 CallCtrl::eek:nAnsweredCall [CM503002]: Call(11): Alerting sip:102@192.168.0.206:18032;transport=udp
    21:13:08.234 CallCtrl::eek:nAnsweredCall [CM503002]: Call(11): Alerting sip:101@192.168.0.207:28526;transport=udp
    21:13:07.953 CallCtrl::eek:nSelectRouteReq [CM503004]: Call(11): Calling: RingAll:800@[Dev:sip:101@192.168.0.207:28526;transport=udp, Dev:sip:103@192.168.0.200, Dev:sip:102@192.168.0.206:18032;transport=udp]
    21:13:07.953 CallCtrl::eek:nSelectRouteReq [CM503010]: Making route(s) to [sip:800@wsd.no-ip.com:5060]
    21:13:07.953 Line::printEndpointInfo [CM505003]: Provider:[Pennytel2] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Sippy] Transport: [sip:192.168.0.1:5060]
    21:13:07.953 LineCfg::getInboundTarget [CM503011]: Inbound office hours' rule for LN:10003 forwards to DN:800
    21:13:07.937 CallCtrl::eek:nIncomingCall [CM503001]: Call(11): Incoming call from 888012@(Ln.10003@Pennytel2) to [sip:800@wsd.no-ip.com:5060]
    21:13:07.687 LineCfg::getInboundTarget [CM503011]: Inbound office hours' rule for LN:10003 forwards to DN:800
     
  5. jits04

    Joined:
    May 2, 2007
    Messages:
    76
    Likes Received:
    0
    1) These are the ports to open on your router: 5060-5062 tcp/up 9000-9015 udp

    Please check your windows firewall too. If you are behind NAT you could disable the service. Otherwise open the same ports.

    William
     
  6. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Hi William,

    And thanks for your reply!!!

    We have no firewall running on Windows, and the machine with 3CX has full outbound access to the internet.

    As for incomming ports, we have routed via NAT port 5060 through to the 3CX machine.

    When we do the 3CX firewall tests - they all come back green.

    Should we be rouding ports 9000 thru 9015 back IN to the server also, or do these only need to be outbound?

    I also notice that you mentioned 5060 to 5062. Were you talking outbound, or creating a NAT rule of these ports inbound?

    Thanks & Regards

    Adam.
     
  7. aguilar

    aguilar New Member

    Joined:
    Jul 19, 2007
    Messages:
    169
    Likes Received:
    0
    hello have you tried DMZ just for test?

    regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Hi,

    Thanks for your reply. It looks as though my problem is the same as the one posted in this thread:

    http://www.3cx.com/forums/incoming-calls-fail-3902.html

    However, since then, I've found if I open up ports 5060 through 5070 it appears to be behaving itself now.

    I'm waiting to hear back from the other in the other thread to see if this made a difference for them too.

    Best Regards

    Adam.
     
  9. wzaatar

    Joined:
    Aug 1, 2007
    Messages:
    90
    Likes Received:
    0
    Hi,

    Change the registration time from the default (Which is 60 minutes) to 2 minutes (120 seconds).

    That will fix your problem.

    Cheers,

    Wadih
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. adza

    Joined:
    Feb 12, 2008
    Messages:
    22
    Likes Received:
    0
    Hi Wadih,

    Thanks for your reply. I have tried reducing the time to 2 mins (and even 60 seconds) but that didn't fix the problem. The only way so far I have found to fix the problem was by opening up ports 5060 through to 5070.

    Best Regards

    Adam
     
  11. wzaatar

    Joined:
    Aug 1, 2007
    Messages:
    90
    Likes Received:
    0
    That's not good. It's a security breach.

    Listen, I don't mind helping you debugging it. Send me an email to wzaatar at mail dot com and we'll exchange AIMs.

    Cheers,

    Wadih
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.