Problem with International Area Code

Discussion in '3CX Phone System - General' started by Dida-BY, Mar 21, 2008.

Thread Status:
Not open for further replies.
  1. Dida-BY

    Joined:
    Mar 21, 2008
    Messages:
    5
    Likes Received:
    0
    Hello everybody,

    i use the newest 3CX Version 5 (v4128) with 5 extensions. All works fine, but my Lancom Voice Over IP Client have problems when i Dial a number, which begins with "+" - i tried to set outbound rules which convert "+" to 00, but I get alway error "invalid number". With 3CX Version 3 it works fine with this outbound rule +49 ==> rrr0 or + ==> r00.
    How can i solve the problem. The following rules in 3cx Version 5 dont work:
    ----
    Calls to Numbers starting with (Prefix): +49
    Strip Digits: 3
    Prepend: 0
    ----- or ----
    Calls to Numbers starting with (Prefix): +
    Strip Digits: 1
    Prepend: 00
    -----------

    Can you help me, please?

    Nice greetings from germany,
    Dida
     
  2. bluefox8080

    bluefox8080 New Member

    Joined:
    Oct 28, 2007
    Messages:
    181
    Likes Received:
    0
    Why do you use the "+"? Most phones does not even have a "+" sign.
    Can you not rather user 00 for International calls?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dida-BY

    Joined:
    Mar 21, 2008
    Messages:
    5
    Likes Received:
    0
    No, our lancom clients handle with "+" not "00", because the contacts are stored in this format in outlook :cry: :cry:
    Can you help me, please?
     
  4. Halea

    Halea New Member

    Joined:
    Jan 5, 2008
    Messages:
    151
    Likes Received:
    0
    Interesting question. Let me share with you what I found when I did research this specific matter on the net some time back. The number that you dial in order to get a correspondent located outside of your own country is generally speaking called IDD for International Direct Dial. Each country has historically determined IDD. In the US it's 011, in Europe it's now 00 for pretty much every country of the union. But it wasn't always so, some European countries used to use 19 etc., until about 15 years ago. The same way, out of town call prefix, which nowadays is 0 for most European countries, used to be 16, etc., depending on the country.
    The "+" sign got eventually defined as a macro to unify all these IDD codes throughout Europe. The local phone exchange would strip the + code and replace it with the appropriate IDD to be used. Interestingly enough, the + code needed to be transferable in the absence of the appropriate character on the dial pad. Therefore, the + sign was coded as a double-zero, or 00. Hence the ultimate selection of 00 as th universal IDD (at least in Europe).
    To answer your question, the + sign needs to be converted to 00 one way or another. Some soft phones do it internally before passing the call number to the central office, some don't; there may be an option to select. As for 3CX, it seems to be permissible to put the + sign in the outbound dialing rules (for the incoming pattern, not for the outgoing); you could then set up the rule in such a way that + gets replaced by 00. All you need to do is to use a "phone" (soft or hard) that has the capability to pass the + character to 3CX unmodified, according to the rule defined above; + will be replaced to 00 by the time it gets to the phone central office. I don't believe that 3CX can issue a + character in the call number.
    Halea
     
  5. Dida-BY

    Joined:
    Mar 21, 2008
    Messages:
    5
    Likes Received:
    0
    Hi Halea,
    thanks for your answer and for background infos as to IDD.
    I can't believe that it is a problem with my lancom softphone, because it works in 3CX version 3 very good. The advantage of lancom advanced voip client is, that it works hand in hand with our plantronics bluetooth headsets. This is amongst others the reason why we are very content with the software.

    In Version 3 of 3CX i set up the same outbound dialing rule, but it don't work.
    Here is the log - i dialed with lancom +498001000

    Code:
    19:56:16.227 Call::Terminate [CM503008]: Call(1): Call is terminated 
    19:56:16.212 Call::RouteFailed [CM503014]: Call(1): Attempt to reach [sip:+498001000@192.168.0.1;user=phone] failed. Reason: Not Found 
    19:56:16.212 CallCtrl::onSelectRouteReq [CM503013]: Call(1): No known route to target: [sip:+498001000@192.168.0.1;user=phone] 
    19:56:16.196 CallCtrl::onSelectRouteReq [CM503010]: Making route(s) to [sip:+498001000@192.168.0.1;user=phone] 
    19:56:16.196 MediaServerReporting::SetRemoteParty [MS210000] C:1.1:Offer received. RTP connection: 192.168.0.15:50030(50031) 
    19:56:16.180 CallLeg::setRemoteSdp Remote SDP is set for legC:1.1 
    19:56:16.180 Extension::printEndpointInfo [CM505001]: Ext.103: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [LANCOM Advanced VoIP Client/6.02.0070.0 (Language=Deutsch) (LineMgr=CLMgr.exe/6.0.2.28) (OS=Windows Vista Business /6.0.0.6000 ) (SerialNo=1607) (IP=192.168.0.15) (MAC=00-10-18-2B-21-34)] Transport: [sip:192.168.0.1:5060] 
    19:56:15.915 CallCtrl::onIncomingCall [CM503001]: Call(1): Incoming call from Ext.103 to [sip:+498001000@192.168.0.1;user=phone] 
    19:56:15.884 CallLeg::onNewCall [CM500002]: Info on incoming INVITE:
    INVITE sip:+498001000@192.168.0.1 SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.15:5060;branch=z9hG4bK-d87543-523f8b1f0c35aa1a-1--d87543-;rport=5060
    Max-Forwards: 70
    Contact: [sip:103@192.168.0.15:5060]
    To: [sip:+498001000@192.168.0.1;user=phone]
    From: "CPR-MG"[sip:103@192.168.0.1];tag=ea695f5c
    Call-ID: 7328b07a3c00cf1a@SFAubWljaGkubG9rYWw.
    CSeq: 2 INVITE
    Allow: INVITE, ACK, CANCEL, BYE, NOTIFY, REFER, OPTIONS, INFO, SUBSCRIBE
    Proxy-Authorization: Digest algorithm=MD5,realm="3CXPhoneSystem",username="103",uri="sip:103@192.168.0.1",nonce="12850944975:0cf8134e9675450caafe0ca8916ddc12",response="020e106085a758fcc2efb1dbb8c8c853"
    User-Agent: LANCOM Advanced VoIP Client/6.02.0070.0 (Language=Deutsch) (LineMgr=CLMgr.exe/6.0.2.28) (OS=Windows Vista Business /6.0.0.6000 ) (SerialNo=1607) (IP=192.168.0.15) (MAC=00-10-18-2B-21-34)
    P-Preferred-Identity: "CPR-MG"[sip:103@192.168.0.1;user=phone]
    Content-Length: 0
    X-IPPBXCallType: 0
    X-IPPBXSuppressRedialListEntry: false
    
    It seems as if my outbound rule dont work:
    Calls to Numbers starting with (Prefix): +49
    Strip Digits: 3
    Prepend: 0

    You can test it and download a trail of lancom voip client:
    http://www.lancom-systems.de/LANCOM.356.0.html?pid=324&L=1

    What do i wrong? Please help me.

    Thanks from Germany, near Munich,
    Dida
     
  6. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    I beg you, RTFM

    Management console, General Settings / e164 Number processing. Set your country code there and E164 numbers (which starts with '+') will work like a charm.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Halea

    Halea New Member

    Joined:
    Jan 5, 2008
    Messages:
    151
    Likes Received:
    0
    I'm impressed. I've been trying to figure out how to use the "e164 number processing" section of the program. Sometimes a little hint goes a long way towards understanding things.
    Halea
     
  8. Dida-BY

    Joined:
    Mar 21, 2008
    Messages:
    5
    Likes Received:
    0
    Hi archie,

    thank you for your hint.
    I already tried this and set up the E164 number of germany:
    Country Code: Germany, Remove if same Country: Yes
    It doesn't work.

    But independent from this, every call (home country or abroad) whose number which begins with "+" fails :cry:

    Hmm.... any idea :?:
     
  9. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Read this: http://www.3cx.com/manual/3CXPhoneSystemManual5/phone-system68.html
    Keep in mind, that it is only PRE-processing. After it is done, outbound rules processing will be applied to resulting number.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Dida-BY

    Joined:
    Mar 21, 2008
    Messages:
    5
    Likes Received:
    0
    Hello archie,

    thanks again for your help.
    I tried again to set up "e164 number processing".
    My problem was, that i have to restart the 3cx service in order that changes take effect. :!:

    Thank you everybody..
    Now 3CX works like a charm 8)

    Nice greetings near munich,
    Dida
     
  11. bluefox8080

    bluefox8080 New Member

    Joined:
    Oct 28, 2007
    Messages:
    181
    Likes Received:
    0
    I found a bug (or missing feature).... South Africa is not listed under the E164 numbers!
    Swaziland and Zimbabwe are listed...

    Anyway South Africa's code is +27

    3CX, Can you please add this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.