Problem with "No available outgoing trunk" but incoming is working well.

Discussion in '3CX Phone System - General' started by Guss Marconi, Feb 19, 2018.

Thread Status:
Not open for further replies.
  1. Guss Marconi

    Joined:
    Feb 19, 2018
    Messages:
    2
    Likes Received:
    0
    Hi Everyone,
    I'm getting a problem with my outgoing calls through my beronet gateway, i checked the events report and have this:
    SIP Server/Call Manager ID: 12289
    Device 2311122 dialed on (AnyLine@BeroNet bero*fix FXO (400/1600/6400)) had no available outgoing trunk(s) for Call(from "Gustavo Marconi"<sip:100@*******.3cx.**>;tag=vD7qVwxEbvGk6PigoXb7Q3QYEvcSD5FN to 2311122)
    However the incoming calls work well through the same beronet gateway.
    I'm installed my 3CX PBX on Debian Jessi in AWS, i'm new with 3CX and I have the feeling that my mistake is something pretty simple, but is almost 4 days and I can't fix it, please help me.
    Regards.
     
    #1 Guss Marconi, Feb 19, 2018
    Last edited: Feb 19, 2018
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Jeezz... get rid of the link you posted to log into your system! :(

    From the bit of log you posted, I'd guess, either an outbound rule issue, the IP & port information in 3CX is incorrect, or you may not have the trunk setting correct with reference to the number of calls allowed on the trunk group.
     
    #2 leejor, Feb 19, 2018
    Last edited: Feb 20, 2018
    flextelecom likes this.
  3. Guss Marconi

    Joined:
    Feb 19, 2018
    Messages:
    2
    Likes Received:
    0
    Hi @leejor, thanks for the advice, i'm hidding the link of my system :D.

    Respect to the outgoing trunk problem, you're right, the IP of my gateway is in my private network and my 3CX server is in the AWS cloud with a public IP, but my 3CX server has no route to communicate with my gateway, i'll stablish a VPN between my AWS VPC and my local firewall and I'll let you know if it works.
     
  4. flextelecom

    Joined:
    Feb 2, 2016
    Messages:
    8
    Likes Received:
    0
    You shouldn't need to create a VPN, you should just be able to create a rule in your firewall and forward the relevant ports from the external IP's.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
Thread Status:
Not open for further replies.