Problem with Remote Extensions

Discussion in '3CX Phone System - General' started by dazzla75, Jan 31, 2011.

Thread Status:
Not open for further replies.
  1. dazzla75

    Joined:
    Jan 31, 2011
    Messages:
    10
    Likes Received:
    0
    Hi I am having real problems with remote extensions. I have been trying stun and the sip proxy manager, but to no avail. I am able to register, but not able to get any audio. My remote extension is a Cisco spa504g. The symptoms are the same whether I used Stun or the sip proxy manager - registered, but no audio.

    On the server side i see the following:

    11:12:35.376 [MS105000] C:5.2: No RTP packets were received


    The PBX side firewall has the following ports opened:

    5060-5062 - Sip
    5090 - Tunnel

    Question do I need to enable RTP? I thought the SIP proxy manager / stun handled this?
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    When setting up an external extension you must ensure you follow our guide to the latter, a common cause is forgetting to switch on nat an setting the RTP packet size to 0.20 . When it comes to setting it up using the sip proxy manager, it is safer to factory reset the phone, and set it up as a normal extensions then proceed to switch off stun and add the proxy address and port.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dazzla75

    Joined:
    Jan 31, 2011
    Messages:
    10
    Likes Received:
    0
    HI Mark, I have triple checked and followed your settings to the letter for a remote extension....still no audio with stun? As for using the sip proxy, that also failed when followed to the letter....no audio
     
  4. Lukas

    Joined:
    Jan 23, 2011
    Messages:
    45
    Likes Received:
    0
    Well, I guess you could count me in for this... I just made another post about the same problem with PAP2... I didn't report about "no audio", but of course I don't have any audio at all since all I can do is register the extension and I am not even able to make it ring...
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    You may want to read the manual, about which ports need to be opened/forwarded....http://www.3cx.com/manual/3CXPhoneSystemManual31/phone-system17.html
     
  6. dazzla75

    Joined:
    Jan 31, 2011
    Messages:
    10
    Likes Received:
    0
    Right, this relates the firewall config at the HQ where the server is. I already have these setup and the 3cx firewall checker passes with flying colours. My question is what ports if any do i need at the remote firewall where the remote extension is? Presumably as it is using stun, none?
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    So then you did open (forward) the additional ports as per the documentation? (ports 9000 +)

    You should not have to do any port forwarding at the extension end. That said...some routers do not play nice with SIP and can cause problems. When you say no audio, is it just in the one direction, towards the PBX? If that is the case then I would suspect the router/firewall settings at the PBX end need to be adjusted. It is rare that the packets are blocked at the originating end.
     
  8. dazzla75

    Joined:
    Jan 31, 2011
    Messages:
    10
    Likes Received:
    0
    I dont need ports 9000 as that is for external VOIP trunks, which I am not using. I am using ATA's locally at each site to route out.

    No audio, full stop. Phones are registered, they connect and dial, jut no audio in any direction......weird....even tried sip proxy, same result......

    I have also noticed the following on the pbx......

    08:47:26.996 [CM506004]: STUN request to STUN server 75.101.138.128:3478 has timed out; used Transport: 192.168.0.11:5060


    which is the secondary stun address configured on the pbx stun2.3cx.com.....?
     
  9. dazzla75

    Joined:
    Jan 31, 2011
    Messages:
    10
    Likes Received:
    0
    Turns out on the spa devices you need to specifically set the stun server to stun.3cx.com:3478.....adding the port number explicitly suddenly made it all work!

    I have another problem now. The 3CX is now sitting behind a Netgear SRX5308 loadbalancing firewall. There are 2 dsl connections on this. Wan 1, Wan2. The dynamic dns points to the 3cx on Wan2, and there are rules to bind stun, sip etc to wan2.

    All works fine whilst Wan1 is down, but when i bring it up and start weighted load balancing, i get the cant receive RTP errors again....anybody have any experience of VOIP and load balancing and how to handle this?
     
Thread Status:
Not open for further replies.