Problem with transfer calls

Discussion in '3CX Phone System - General' started by Dida28, Sep 27, 2007.

  1. Dida28

    Joined:
    Aug 8, 2007
    Messages:
    9
    Likes Received:
    0
    Hi,

    i am from Germany and i use 3CX with some cisco phones 7940 series. Now we want to use some softphones from LANCOM named: LANCOM Advanced VOIP Client. All works great, but we have a problem when we transfer a call from a softphone to another extension, independent from target (CISCO or other softphone). When i try to transfer a call, then the person who will be transfered hears no on hold music, but the bell signal. And when the targetextension answers the phone, the person who should be transfered hears the on hold music and the transfer goes back to sourceextension.
    And we get this error in log:

    Code:
    [CM101000] Registration request from sip:101@192.168.0.1 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings 
    22:40:53.724 AuthMgr::requestCredential [CM001005] Message SipReq: REFER 3cxPbx@192.168.0.1:5060 tid=02358569854d2a27 cseq=REFER contact=101@192.168.0.25:5060 / 4 from(wire) failed authentication! 
    
    Can you help me please? :roll:

    Nice greetings from near munich..
     
  2. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    Could you supply a bit more info? Are you trying to transfer TO 101? Was 101 registered with 3CX before transfer was attempted? Call is being transferred from what type of device / softphone to what type of device? And just to ask the obvious - did you check the ID and password for 101?
     
  3. Dida28

    Joined:
    Aug 8, 2007
    Messages:
    9
    Likes Received:
    0
    Hi Mirzab,

    sorry for my unclear post. I try to give you more Info.

    Here is my 3CX-configuration:
    5 Extensions: 101, 102, 103, 104, 105
    102, 104, 105 are connected to Cisco phone 7940 Series
    101, 103 are connected to Lancom Softphone: Advanced VoIP Client, a nice softphone, which works hand in hand with Outlook.

    My 3CX is connected with the PSTN Gateway Patton SN 4552 to ISDN.

    All works fine. I can call internal and external with all extensions and all incoming calls works fine too.

    The error happens, when I want to transfer a call from the softphone (e.g. 101) to another extension (e.g. 102,104,105).

    In this case, i tried to transfer a call from 103 (softphone) to 101 (cisco 7940).

    Code:
    [CM101000] Registration request from sip:101@192.168.0.1 failed. Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings 
    22:40:53.724 AuthMgr::requestCredential [CM001005] Message SipReq: REFER 3cxPbx@192.168.0.1:5060 tid=02358569854d2a27 cseq=REFER contact=101@192.168.0.25:5060 / 4 from(wire) failed authentication! 
    

    Was 101 registered with 3CX before transfer was attempted?
    Yes, of course. All extensions are always registered.

    Was 101 registered with 3CX before transfer was attempted?
    Yes, of course. If extension wouldn't be authenticated correctly, we couldn't make outgoing or answer incoming calls.

    Please let me know, if you need more infos and thank you for your assistance.

    Nice greetings from Germany near Munich, Dida
     
  4. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Hi Dida,

    Please try to remove password for those extensions at both extensions setting at 3CX box and SIP phones. Set the password filed to blank. It may be fixed your problem.

    Let me know it works or not.
     
  5. Dida28

    Joined:
    Aug 8, 2007
    Messages:
    9
    Likes Received:
    0
    Hi 5qg4,

    you are right, after I blanked the passwords of all extensions it works. 8)

    But where is the problem?
    Is there another way to fix it.

    And another question is, why hear the tranfered person no hold music, when I transfer via softphones? :?:

    Thank you very much,
    Dida
     
  6. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Hi Dida,

    It should be a workaround solution. May be 3CX will fixed this issue soon.

    Please provide the console log for this issue. It may be in help to solve it faster.
     

Share This Page