Problems Auth User

Discussion in '3CX Phone System - General' started by sebasct, Jul 5, 2007.

Thread Status:
Not open for further replies.
  1. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0
    Pardon by my English.

    I read different post in this forum and nonencounter the solution.
    I must formed the following VoIP account, with these data:

    sip server: sip.xxxx.net
    port: 5061
    user: 63852893
    pin (Auth to user): 19hchz2086
    password: lcwmxxxx

    Profit not to find the square to add the Auth User. These are the data that the state of the servant shows:

    20:02: 22,459 ClientRegs:: onFailure [CM113010] Next registration will be attempted in 10 you make a draft

    20:02: 22,459 ClientRegs:: onFailure [CM113006] Registration of sip: 63852893@sip.xxxx.net: 5061 there are failed; reason=SERVICE UNAVAILABLE

    20:02: 20,867 ExtLine:: Register [CM110004] for Send registration <sip: 63852893@sip.xxxx.net: 5061>

    20:02: 20,726 ExtLine:: Register [CM110003] Use both (External and Internal) for IPs device line registration DN='10000' device='Line1'

    Thanks! :cry: :roll:
     
  2. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    You should use only external IP for registration. Make correspondig settings in advanced options of voip provider's settings.
    Auth-id you can set in line settings for that line.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0
    archie, I cannot find those options. I have to the version free, without activating. Thanks.
     
  4. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    It doesn't matter. these optons are present in free version too.

    To set correct registration IP - go to Lines/Manage, click on your provider and you will get 'Edit VoIP provider' page. Expand section 'Registration settings' and in the field 'Which IP to use in 'Contact' field for registration:' select 'External (STUN resolved)'.

    Than, open line configuration page, auth-id is just on it, you won't miss it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0

    archie, moan not to be able to form 3CX correctly. I follow all the steps and I do not obtain results.

    1) If select "External (STUN resolved)", in Server Status it marks SERVICE UNAVAILABLE.

    [​IMG]

    [​IMG]

    2) If make this form the configuration in Server Status of gets to me to [CM113006] Registration of sip:19hchz2086@sip.bxxel.net:5061 has failed; reason=Request Timeout

    [​IMG]

    3) In no case establish a connection
    [​IMG]

    I have a generic service of Buenos Aires. There is something forming bad and I do not realize.

    Pardon and thanks again. :wink:
     
  6. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    First, Service Unavailable means that 3CX can not resolve FQDN of STUN server. Enter IP of any working STUN server in general settings.
    Second, your inbound rule directs incoming calls to ext. 999. And you haven't defined such extension. You have te only ext. 140 which is not registered. Make it register against 3CX PBX and direct inbound rule to it.
    Third, check your forwarding rules. You should allow mapping of port 5060 outbound and inbound.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0
    archie

    1) Modified the STUN
    [​IMG]

    2) Modified the extension
    [​IMG]

    3) Opening of ports
    [​IMG]

    The options finished to me :lol:
    Your you think that it is problem of my connection?
    Thanks.
     
  8. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    All seems more or less correct, but don't set Outbound Proxy for VoIP provider, keep it blank.
    After you did such changes does it affected the system anyhow?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0
    archie, I made all them change, leaving in target Outbound for Proxy VoIP provider. It does not notice changes, which if I realized that in other IP PBX the registry becomes in 63xxxx93@sip.xxxl.net:5061 but in 3CX 19xxx2086@sip.xxx.net:5061

    In other IP PBX it works with the first option, but in 3CX not as to form it of that form.

    Thanks!
     
  10. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Sorry, but I can not understand your language.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. John2007

    Joined:
    Apr 14, 2007
    Messages:
    16
    Likes Received:
    0
    Forget 3CX, it does not support voip providers which use auth ID different to user ID.
     
  12. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,084
    Likes Received:
    131
    Yes unfortunately you are right. we only support provider accounts that have the same username and authentication ID.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. sebasct

    Joined:
    Jul 5, 2007
    Messages:
    6
    Likes Received:
    0
    thank you very much. I will put myself in contact with my supplier to evaluate the situation. pardon the language :wink:
     
Thread Status:
Not open for further replies.